2 USB ports down

  square eyes 16:44 20 Sep 2003

As a result of trying to figure out a problem with gamepad software i re-installed my USB drivers and now 2/4 dont work. Pressed the wrong button somewhere as i dont understand the USB settingss

Please help

  JIM 16:49 20 Sep 2003

Post your win/os plus how long before your system had problem.

  square eyes 17:02 20 Sep 2003

My PC specs are:Windows XP 640mb ram, Radeon 9000 pro 64mb, 2100 Athlon processor, Audigy soundblaster 5.1, and I use a TFT Monitor.

I had moved house and set the pc back up again and my gamepad wouldn't work properly although it was communicating to a certain extent. The light wasn't coming on and no profile launcher.
I ended up wrecking the system so repaired xp but still the same problem.
I tried to re-install usb drivers and now only two are working.
Ad usual i have given myself another problem, but im sure the usb can be activated somehow but am still stumped as to why the controller wont install proplerly.

Any ideas??


  JIM 17:22 20 Sep 2003

in device manager are root hubs checking out as some no problems and some showing conflict?

have you used the driver roll back or tried the trouble shoot in the Root Hub Properties, Help and support.Try the following if not already done firstand see if you get anywhere.

EG. when OPENED.

Is there a problem with the USB host controller or the root hub?
If there is a problem with the USB host controller or the root hub, a USB device might not work.

To check the status of these devices

Open Device Manager.
Double-click Universal Serial Bus controllers.
Right-click the entry for your USB host controller, and then click Properties.
Look in the Device status box to see if it mentions any problems with the device, and then click OK.
Click USB Root Hub, and then repeat steps 3 and 4 for this device.

To open Device Manager, click Start, click Control Panel, click Performance and Maintenance, and then click System. In the System Properties dialog box, click the Hardware tab, and then click Device Manager.
Is there a problem with either of these devices?

The Device status box reports a problem with the USB host controller. Or, no USB host controller is listed on the Device Manager tab.

The word "unsupported" appears next to the USB host controller.
The Device status box reports a problem with the root hub.
The Device status box reports that both of these devices are working properly.

  square eyes 17:43 20 Sep 2003

Thx Jim, i managed to solve problem by rolling back the driver for via usb enhanced controller but my USB 2 dissapeared.

Ok, all of my usb are working now but still left with the gamepad not installing correctly.

This controller had worked fine for a long time and i know its not faultly because i even got a replacement new one and still the same.

On the software for the gamepad there is a saitek magic bus & mouse which i can usualy install (dont know what they are though) and worked ok, but now its installs the basic drivers but install the later as unknown device.

If i try to launch the "profile launcher" it says "please plug in a saitek programmable controller when the controller is in.

This has happened before but fot the life of me i cant remember how it was sorted.

I dont think all communication between usb and the gamepad is correct.

I wait with bated breath

many thx

  JIM 18:25 20 Sep 2003

I hope iam following you right, but if not the following is the norm. Uninstall the software for the saitek gamepad and
suggest you delete/uninstall after right hand click, the unknown device which is in the device manager? and any references to your gamepad controller in device manager.

Reboot your system and load the software for gamepad but do not connect USB saitek programmable controller untill after you have closed down windows.Startup windows and let the plug and play pick it up on bootup.(i hope) there is option in control panel if not working with plug and play.

Now this is what they say.

First, install the included Saitek Extensions software. Next plug the throttle into the Control Stick via the included cable, then plug the Control Stick into a vacant USB port or game port and you're ready to go. It?s really that easy.

  square eyes 19:27 20 Sep 2003

Thanks for your time Jim, but still no go.
I have a controller like the playstation's and not a joystick.

I've tried everyway to install it.

This is what happens.....

No related software on pc......
Put in disk and it starts installing drivers.
It then asks you to plug in controller
It detects it and asks you to press the configure button.
Usualy at this point the light on the controller is on (when working ok)

It then says driver installation complete, press next to launch the test screen, when pressed, the final installation windows appears but no test screen.

It then loads the software (while on the task bar it's syaing found new hardware ect)

At this point usualy the two types of software are saitek magic bus and magic mouse but in this case it tries to install software for unknown device, doesn't seem to recognize the controller is programable. After this it states there might be a problem with my new hardware.

The controller cant be used.

Is there a rechnical help line at premium rate that i could ring?

  JIM 19:50 20 Sep 2003

Thinking caps is back on but doing a search produced.

Saitek Gaming Action Pad and Gaming Mouse

from Saitek
This item is no longer available, please use the new navigation to the left or one of the links below.So far no joy.There have been problems reported with the software but keep:)

  JIM 20:03 20 Sep 2003

i am getting the impression from the reviews of your pad that it may not be Winxp compatible.can you confirm that it has been ok with xp in the past? Did you have the option of drivers for win2000 by anychance.

  JIM 20:08 20 Sep 2003

Go to link and download latest drivers for Winxp,hope your on broadband. ;)

click here

click here

  square eyes 22:11 20 Sep 2003

Maybe i didn't explain myself properly.

The gamepad has been working for 10 months, the only thing i did was pack it all up in a box, move house and unpack it. I switched it on and a problem. Im sure i was told how to put it right ages ago.

It is a saitek 2500 rumble gamepad.
Im sure its down to settings, i have a wingman controller, not programable (bog standard, cheap & chearfull) and it works fine.
The USB connections dont seem to cope with something that is programable.

Im getting greys hairs over it as the pc has been crashing with blue screens sometimes when i've been yanking the lead in & out trying to instal it, so i will ring a techi on Monday.

Thanks for your help

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique