10 in 1 card reader has bizarre behaviour!

  mw55309 19:34 09 Feb 2005

I recently bought a 10-in-1 card reader. Here are the symptoms:

1) Works fine on my windows XP laptop (Quite old Dell, USB 1.1) with all types of card, all sizes of card

2) SD and Sony memory stick pro 32Mb works fine on Windows XP Desktop (brand new Dell, USB 2), BUT 512Mb card does not work; I can read from it, but when I try and put files on there, the first file transfers and then I get a "Disk is write-protected" error message, followed by windows not recognising the device!

I have tried - uninstalling and reinstalling; restarting PC with card reader connected and disconnected; tried uninstalling and manually putting Win2k/ME/98 drivers on there; all six of my desktops USB 2.0 ports. Always I get the same error.

What annoys me is that it works on my XP laptop without any fuss, suggesting - it's not the driver, it's not the card, it's not the card reader, and it's not Dell (since both my lappy and desktop are dell). So - wtf is it??

Any help MASSIVELY appreciated.


  mw55309 22:01 09 Feb 2005

Looks like I got even the all knowledgeable PC Advisor message board stumped...

  mw55309 14:17 10 Feb 2005

Come on, really, has no-one got any ideas???

All i got from Dell was to use the system restore facility to see if that works! Yeah Dell, I'm going to wipe my entire system just to see if it fixes my USB card-reader...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?