SWTOR: Computer freezes after clicking play on launcher?

  ABCodimus 07:59 24 Aug 2013

Hello, I am new to this forum. Recently I decided to install SWTOR, so I downloaded it, but when the game became ready to play and I clicked the play button on the launcher, the system froze. No error reported, no black screen or blue screen, nothing whatsoever. A complete freeze. I was forced to hard boot. Now, my graphic card was 8400 GS, so I decided to buy Nvidia gt 630 2gb ddr3. But even after installing the new card, the problem persists. I can't even post on SWTOR forums and get help, as my account is f2P. I have 2gb ram, and Service Pack 3. OS is Windows XP 32 bit. It is highly frustrating, downloading a 25 gb game and seeing that it's not working. According to most websites, my system has the requirements needed for playing this game.

  Chronos the 2nd 08:20 24 Aug 2013

Have you tried looking here SWTOR Community. If you look under Customer service there is a stickie thread on launcher issues.

If no joy there come back and I'll see if there are any other solutions.

By the way you have h=got the latest drivers for your new graphics card installed rather than the old ones that came on the disk?

  ABCodimus 08:34 24 Aug 2013

I have looked there, and tried most of the solutions, but none worked. I now used the Launcher Repair Utility, so the game is again installing. I'll see if it works. In the meantime, I'll update my drivers. All I have to do is go to nvidia website, and search for drivers, right? In that case, I am getting the 320.49 update.

  Chronos the 2nd 08:43 24 Aug 2013

Go here and either put your GPU details in (option 1) or simple go to Option 2: Automatically find drivers for my NVIDIA products and click on Graphics Drivers.

But you are quite correct the 320.49 is the latest driver.

  ABCodimus 11:03 24 Aug 2013

Ok I updated driver. Will wait for Swtor to finish patching, then will try to relaunch. Will tell results tomorrow.

  ABCodimus 07:21 26 Aug 2013

It doesn't work even now :(.

  ABCodimus 07:55 26 Aug 2013

I can post dxdiag if required.

  Chronos the 2nd 09:27 26 Aug 2013

Sorry to here that. OK, lets have a look at what the event viewer is logging. Instructions. Run the game and after it fails go into the event viewer. As per the instructions click on what should be at the top of the list and take a screenshot and post back here.

  ABCodimus 11:00 26 Aug 2013

Problem is, my system has not posted the event. This is because the PC freezes instantaneously, and the only thing I can do is hard boot. So, the error is not listed.

  Chronos the 2nd 11:49 26 Aug 2013


Try this.

Open your Start menu and type "View Reliability History" into the search box.

Select the most recent SWTOR.exe failure denoted with a red circle with a white X in the middle.

Double-click the related Critical Event under Source.

Copy the full description to the clipboard and paste this in to your reply.

Or this way.

  ABCodimus 13:33 27 Aug 2013

I have an XP, so reliability history is there in the form of the event log, or so I presume. What's more, the PC freezes immediately. I don't even get a bluescreen so I don't think that there would be an error logged. I even left it running for a while, but nothing. The thing remains like that, with the desktop frozen, I cannot move the mouse, I cannot use the keyboard, I cannot do anything.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

Comment utiliser l’Apple Store Éducation ?