Hard to be a god

  kalignorgna 16:31 10 Jan 2010

win7 ultimate 64bit

on my main account and on win7 admin account when I try to play the game it comes up with a message "Insufficient privileges: you must be administrator when you run this application for the first time". this message comes up even when I right click and click to run as administrator. i have checked the properties tried to run the game in compatibility mode, checked the security tab and given it full control to no avail. i have also gone into user accounts (advanced mode) and changed my account to admin from custom and i still can't get past this message.

  Kevscar1 23:10 10 Jan 2010

Try uninstallng then right click o dvd drive eft click explore find the setup icon right click clcik instal as adminstrator. it,s worked for me on Vista 64bit

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?