Can't move in any games with keyboard controls W10

  calum.mcmanus 01:33 24 Jun 2017
Locked

I can not move any character in any game what uses keyboard controls.

I have already tried: Using a different keyboard, Using a difference usb port, Restarting the computer, Removing all over controllers from device manager, Rebind movement keys in game, Using a xbox controller (I can play fine with this), Changing registry setting to make keyboard the primary input, Disabling all anti-virus/realtime-scanning, firewalls etc.

Completely stumped, one strange thing is that when I tried to change my input language to English US from English UK, all the settings change, my date changed etc BUT the keyboard layout remained the same (even when I removed all other languages and set the override to US in advanced settings), tried changing this as someone online recomended it but found it odd that even with US as my only language pressing stuff like Shift + 2 still have me quote marks not a '@' symbol.

Running out of places to ask and just to confirm, This is happening in ALL game that use KEYBOARD MOVEMENT (e.g. Diablo 3 works fine as it uses the mouse to move). Also that everything else works in game on the keyboard only movement regardless of what I bind the movement keys too!

And also to confirm that everything works just fine in every other case, only keyboard movement games :(

I don't know what else to try :(

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6T to be sold on contract in UK from O2, EE and Vodafone

Adobe takes the limits off Typekit, renames to Adobe Fonts

Surface Laptop 2 vs MacBook Pro

Où acheter un Mac ?