Why won’t my D40 talk to my laptop?

  Ex plorer 15:34 20 Jan 2011

I want to down load images off the D40 to the laptop it used to work fine on this lappy

I have researched the problem on the net over the past two days and I see it can be a problem.

I have the original software 15.1 that came with the 40D and also the latest 18.0 on a original canon CD.

I deleted the original software 15.1 and reloaded it again switched on the 40D and no result a message read (Device driver software was not properly installed).

I then restarted the laptop and switched on the 40D and the camera loaded the drivers successfully, unfortunately I still couldn’t transfer images.

Next I deleted that software and tried the latest 18.0 and did as above with the same results.

I deleted the USB drivers and restarted and the drivers were reassigned I connected the 40D and laptop switched on the 40D with the 18.0 software this had no effect at all only the message (Device driver software was not properly installed).

I got this message at one time and researched it
Currently, this hardware device is not connected to the computer. (Code 45)

I do remember a short while ago my canon scan would not talk to the laptop I did get round it somehow after a day or so fiddling with it.

The camera dose not show in Add Hardware.

I have now ordered a USB card reader to get round it for now but I still would like to understand the problem.
Would a new transfer cable be worth a try

  Fruit Bat /\0/\ 20:20 20 Jan 2011

Device driver conflict

Unplug your scanner / D40

Use USB device view click here to uninstall (removes from registry which normal uninstalling in device manager does not do) ALL devices that are shown as NOT connected

Reboot the PC
reconnect the device and windows will find and install new hardware, your devices should now be recognised ok.

  Ex plorer 12:57 23 Jan 2011

Fruit Bat /\0/\
Hi down loaded program tried to delete the canon 40D USB and restarted but the same result camera wont load.
I did notice that the USB that I deleted remained at the set date not at to-days date after reeboot.

Port_#0001.Hub_#0008 Canon EOS 40D Still Imaging
Safe to unplug No 3146
USB Hub No 0.2
Connected No 06
Disabled No

Hub 2, Port 1 WUDFRd WUDFRd.sy WPD Canon Inc.
Driver Version 6.0.6002.18112 this is the version that came with the 40D

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

25 book design and illustration tips

iMac Pro review

Idées cadeaux pour geeks et tech addicts