Samsung Ace not recognising SIM card

  bigfooted 12:19 23 Mar 2015

I have a Samsung Ace GT5830i smartphone which has been trouble free up to now. I torned it on today after a battery charge and the phone appears to have stuck in a loop at the opening screen. Normally the phone opens with a screen showing the make and model, it then goes through an opening process showing another screen for a few seconds and then opens at my home page which I swipe to open the phone for use. Today the phone keeps switching between the first two screens in a continual loop and is unresponsive to any controls including the on/off button.. I have tried removing the barrery and leaving it out for a couple of minutes then turning the phone on, I have also tried taking out the SIM card and refitting it but to no avail. I connected the phone to my PC and opened Kies program which promptly told me there was no SIM card in the phone so the program could not run. The battery is fully charged, the SIM card is on a monthly contract which is up to date and I have tried slipping a thin piece of plastic behind the SIM card in case it was not making proper contact with the phone terminals but none of this has worked. I am unable to re-set the phone to factory settings as I cannot get past the first two screens to access settings. All and any suggestions welcomed.

  mole1944 15:07 23 Mar 2015

Google hard reset for it ,but remove the sim card first,i got rid of my ace nice phone but a woeful amount of memory,now got a galaxy S3 that's much better.

  bigfooted 13:52 24 Mar 2015

Thanks Mole 1944 for the quick reply. I have been looking at Google and YouTube and most of the advice is centered around re-flashing the firmware. I am a bit dubious about this as it does say that if you do it wrong the phone is useless. The other problem is that I cannot get the controls to work so cannot get to the donload screen( supposedly pressing and holding the volume down key and power key at same time for 15 seconds). All that happens is the phone re-boots and goes back into the looping mode again. I have taken it to a repair shop and they are going to have a look at it and let me know. I will post back if they can fix it. I agree with you on the lack of memory but I only use this phone for keeping in touch when on holiday or away for the weekend so memory is not an issue for me, I use a different phone for day to day use.

  mole1944 05:49 25 Mar 2015

Try this i used it when i got rid of my ace to clear everything. click here

  bigfooted 13:42 27 Mar 2015

Just got the phone back from repair centre, they re-flashed the firmware and it is working again. Cost £15.00 but better than trying myself and wrecking the phone. Thanks again to forum members for help and advice. bigfooted

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)