'Robin Hood' on Blu-Ray playback

  tigertop2 14:45 21 Sep 2010

I have a Blu-Ray DVD of the new Robin Hood film. For some reason it will run on my Panasonic Blu-Ray DVD player linked to to my Panny TV. However the main film disc will not run on any of the 3 PCs I have which are all fitted with Blu-Ray and run Cyberlink Power DVD 10 Ultra mark 11. however the second disc, 'Director's Cut' runs fine on them as do all other Blu-Rays. I have even tried 'any dvd' but still the same problem. The region set is Europe which is compatible with the DVD. I have updated all drivers. Has anyone else found such a problem and does anyone have any suggestions on what the PCs' problem might be?

The monitors are HDCP capable at 60HZ and in one case at 120HZ. I can understand maybe one PC not playing it for whatever reason but 3 PCs all running Windows 7, 32 Bit and 64 bit. is baffling

I also note other sites report problems of slow loading of this particular DVDand I noticed that on the TV but I am certain that is not behind this problem . Suggestions welcomed

  JoeVasques 16:30 21 Sep 2010

I have exactly the same problem... Have a huge collection of Blu-Ray's, never had a problem on either my laptops or desktop. I even traded the original buy in the shop, thinking it was faulty. But still the same issue with the new copy.

Please advise.


  tigertop2 10:03 22 Sep 2010

I have downloaded the very latest Cyberlink patches released on 14th September 2010. They made no difference. There is seemingly something wrong with the encoding on this first disc which contains the main picture. Maybe I have to go to the DVD's distributor in the UK, whoever that is, to find out what is going on.

It would be interesting to know if anyone else has found playing 'Robin Hood' on Blu-Ray a problem.

  Nigel-1619085 10:36 22 Sep 2010

Yep. Same problems. Runs through the trailers and gives me a blank (black) screen instead of going to the movie menu. Used the same software as tigertop2.

If this is the way forwards, I'm concerned...

If anyone reading this has any suggestions, please tell help us.


  Nigel-1619085 11:27 22 Sep 2010

Arcsoft TotalMedia Theatre 3 Platinum. Downloaded the trial version and it works!!!

It will tell you that the audio decoder is missing, but ignore that. Audio is fine. Takes a little while to load up, but playback works fine.

  tigertop2 11:33 22 Sep 2010

Fine, but I want to know why it won't work on my existing software, both Cyberlink and 'any dvd'
I don't really want another piece of software on a trial basis but thanks for the info.

I have now sent the problem to Universal Studios in the UK as they are the distributor. I know others are having a problem and it needs to be sorted for all

  tigertop2 20:23 24 Sep 2010

Universal( UK) have so far ignored my attempts to find out what is going on with this DVD issue. I will keep trying but would ask that others with the same problem also try asking them. Sooner or later they might deign to respond! I understand that others in other countries may be having the same problem so it looks like a world wide issue.

  Nigel-1619085 20:50 24 Sep 2010

Alright. Have just contacted them. Lets see if they respond

  tigertop2 09:28 25 Sep 2010

Thanks, RoastedPuma. I suspect we may have to go to Universal's Public Relations people in the end but appreciate your action.

  tigertop2 20:13 27 Sep 2010

Universal studios who issued the 'Robin Hood' DVD movie have now confirmed to me that the playback on Blu-Ray is a Cyberlink software problem. They have been in touch with Cyberlink who 'hope' to issue a corrective patch next week.

Yet again Cyberlink caught with their pants down on their software releases. They made a complete nonsense on Blu-ray play back on their Power DVD 10 software and tried to pretend it was OK before releasing an urgent patch. Now this. One wonders if anyone in Cyberlink is checking on their developement labs in Korea before issuing software

  jfell-1620020 07:19 29 Sep 2010

my blu-ray is working properly.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Why this awful City of Los Angeles job ad for a graphic designer is actually brilliant

iMac Pro review

Les meilleures prises CPL (2018)