Not registered on network error

  Columbo fan 14:35 12 Nov 2016
Locked

I have a Samsung A3, it recently updated and since then whenever I try to call or send a text I get the 'Not registered on network' message. I have tried going into settings and searching for a network but either nothing comes up or even if EE (my network) is there and I select it I get the 'registering on network' message and the loading symbol but then it doesn't register. I tried taking the sim out and holding the power and volume button to do a restart but still no luck. I have only had this phone for a few months, I bought it to replace a Sony phone which after an update also stopped working (turns off saying no battery even at 100%) and I really can't afford to buy another new phone especially when the same thing could happen again with another update. Please help!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Note 10 Now On Sale: Price, Specification & Features

Best free Photoshop brushes 2019

Apple TV streaming service: what, where, when and how much

Les meilleurs écouteurs et casques audio Lightning (2019)