how to remove file that does not exist on microsd?

  theDarkness 12:22 20 Mar 2011

after what I think was a bad save on a nokia (a switch off during the process), I am trying to remove the same file that shows up on a microsd card, but when trying to remove it, windows states that the files do not exist? The nokia software also gives a similar message, do I have no option but to re-format the entire card?

  Kevscar1 15:13 20 Mar 2011

reformat the card

  theDarkness 21:38 23 Mar 2011

I tried that, it does work, but I often have the same issue reappearing, so Im wondering if the card is likely to be on its last legs. I have a digital phone+digital camera, and have tried the card on both (fully formatting before trying either). All files save correctly, eg when taking photos and then viewing the file system (using either a pc or the screen of either) it might show :-
Photograph2.tif etc

but often I will get "Photogr.aph3" together with the correct "Photograph3.tif" which is very odd. Its not as if the photo hasnt saved correctly, as I can move the tif to a pc and view or edit it on its own. The oddly named file remains undeletable. The memory card is a sandisk sdhc, which Im now thinking may simply be corrupt, reformatted/empty or not

  Kevscar1 16:10 25 Mar 2011

Try right clicking the file and looking at properties but it does sound as if the card might be corrupted if reformattimg doesn't stop it

  theDarkness 23:29 25 Mar 2011

I think u r right in the card being corrupt, if a non-quick reformat does not fix the issue, then Im wondering if I have no option but to simply bin it? The problem most likely occurred if the card was taken out mid read/write

  Kevscar1 03:43 26 Mar 2011

Why bin it all the photos are being saved. Keep using it but have a spare ready for when it packs up completely. You may be able to use it for years yet.

  cycoze 16:52 27 Mar 2011

try renaming the file from "Photogr.aph3" to "Photograph3.tif" or "Photograph3b.tif", then see if it will delete.

  JoeC 18:27 28 Mar 2011

but it worked for me when I had exactly the same problem.
If memory serves me correctly I did it this way:- right click on card, select Properties, Tools, Error Checking, Check Now.
A box came up and I put ticks in both boxes (Automatically fix file system errors, and Scan for / attempt to recovery bad sectors).
Once I had done that, the card worked perfectly.
I hope it works for you.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?