2 dead sim cards one new one old

  flat-pack 10:21 29 May 2017
Locked

Recently took up offer of sim only deal to replace current network, also on sim only.

When I loaded new sim into phone, Sony M2, instead of the expected unlock message I got 'no sim no service'

Cleaned card and tried again, same result, when I put old card back in I got same message, phone is now useless.

Anyone have any ideas or suggestions ?

Graham

  alanrwood 10:52 29 May 2017

It might help if you posted what sim you are trying to use on what network.

Had a similar problem with a Vectone sim (piggyback on EE) and I sorted it by using the SIM Toolkit App, selecting the sim and setting it to UK only. Maybe you have something similar on the Sony or with you network.

  alanrwood 10:54 29 May 2017

Just thought, is your phone unlocked to start with or is it still tied to a specific network.

  flat-pack 09:24 04 Jun 2017

My phone was/is locked to vodafone, the new sim was supplied by BT. Currently running BT SIM happily in old phone. I can only find one SIM toolkit in play store and it suggests philippine use only ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Amazon Prime Day 2018: Best Deals & Launches

Say aloha to the summertime vibes of artist Kim Sielbeck

The best Amazon Prime Day Apple deals 2018

Les meilleures séries Amazon Prime Video (2018)