Please save me with my Mac! Lost access to lion&recovery partition,got windows&linux to help though!

  Jwbjnwolf 01:09 12 Nov 2011
Locked
Answered

My Mac has Mac os x lion 10.7.2 on with windows 8 developer preview next to it. I accidentally somehow convert all the partitions to logical partitions which made windows and lion unbootable. I have reinstalled windows, so that's bootable now, And windows classes the lion partitions as unformatted disks and keep asking me to format them.

I have a retail copy of snow leopard install disk, a live cd of Ubuntu 11.10, and a 2TB FireWire hdd.

I cannot get to the recovery partition either as same thing has happened with that.

Tried installing snow leopard to FireWire hdd, but I get an error.

Ubuntu live cd will recognize  the lion partition but I cannot access the most important data on the partition such as work, my video editing I done etc.

Some of the folders Ubuntu classes as unknown FILES, instead of FOLDERS,  and 90% of others are coming up with I don't have the permissions to view.

The file system that lion is on is hfs+ journaled, so I am stuck what to do there.

With snow leopard install DVD, I cannot edit the partitions or anything whatsoever apart from wiping the whole drive and starting from scratch, which ain't gonna happen until my important data is safe and snug on my FireWire hdd and netbook.

I have an iPod touch 4 64gb with almost 15gb of space left so that is gonna be a big problem getting back into sync with iTunes after reinstall.

My iPod has around 15gb of very important photos, 4gb music, 5gb of movies/personal important videos, a lot of PDFs in iBooks, around 20gb of apps that use daily, and a lot of the apps have data.

The Music is all from CDs, but that I have copied to my netbook, but videos and all apps and data etc needs to be somehow not lost.

I have Sims 3 on Mac with lots of saved data, which I would love not to lose as spent so hard getting stuff perfect, including an almost exact replica of my home.

I have lost lots of personal irreplaceable data before which has really left huge holes in memories and am determined to lose much more.

Which would be less complicated? Somehow transferring my data via Linux or windows?

And if impossible, how can I remove the journaling from within  Ubuntu or windows?

And please, please, please, PLEASE say I am not doomed, as I am so close to backing up my data, but I have permissions and journaling barring my way.

Thanks for any help,  Jase 

  Jwbjnwolf 20:46 12 Nov 2011

[email protected]:~$ sudo df -h

Filesystem------------Size---Used---Avail--Use%--Mounted on

/cow------------------1.9G---53M----1.9G---3%--- /

udev------------------1.9G---4.0K---1.9G---1%----/dev

tmpfs-----------------778M---836K---778M---1%----/run

/dev/sr0--------------698M---698M----0----100%---/cdrom

/dev/loop0------------663M---663M----0----100%---/rofs

tmpfs-----------------1.9G---8.0K---1.9G---1%----/tmp

none------------------5.0M---4.0K---5.0M---1%----/run/lock

none------------------1.9G---104K---1.9G---1%----/run/shm

[email protected]:~$

I hope that make sense I do not really understand which is which

but the mac partition with all data is around 700gb

  Jwbjnwolf 20:59 12 Nov 2011

One of them on

http://ubuntuforums.org/showthread.php?p=11450842&posted=1#post11450842

Said to do this:

Code: sudo cp -Rp /path/to/your/home /path/to/your/backup

How would do this?

  LastChip 00:03 13 Nov 2011

Sadly no, it's not making sense, if you think the MAC partition is around 700GB.

If you're running Ubuntu from a DVD, it may be listing the DVD rather than the hard drive.

Try a different approach and this command, which does much the same but in a different form:

sudo fdisk -l

(that's lower case L not a one)

WARNING: DO NOT use any other switch except a lower case L - which is list and wont do any harm.

That should list the hard drive(s) partitions and the type of partitions they are.

I suspect the hard drive isn't mounted in Ubuntu and what I'm trying to achieve, is to find out what has been allocated to your MAC partition in order to tell you how you can mount it and recover your data. Once you have the data safe, you can do what you like with the computer and if necessary, start from scratch.

To be honest, I'm a little concerned you've reinstalled Windows. How do you know it didn't format your data partition? That's why I said, don't install anything else until you have this under control. The fact that Windows can't read a MAC partition, certainly does not stop it from formatting it.

  Jwbjnwolf 17:29 14 Nov 2011

It is already mounted in Ubuntu but every other file/object is denying access due to "permissions"

So it is more than clear that nothing on the lion and recovery partitions have been lost except a corrupt partition table.

Gparted classes the internal drive as unallocated and says the partition table is corrupt.

I think my lion is angry with me don't you?

I tried:

sudo cp -Rp /path/to/your/home /path/to/your/backup

By dragged and dropped the paths to what and where I want to back up, but again that is coming up with permission denied.

Know a computer technician that apple recommended to us and hope he has a MacBook, as then can try via hooking it up to my angry mac via FireWire to try and get the data across that way.

  Jwbjnwolf 17:33 14 Nov 2011

Also I can read everything on the recovery partition.

So it would seem that they should be ok, and should be bootable, but there is the corrupt partition table causing this.

  Jwbjnwolf 21:39 04 Dec 2011

Had guy out that got recommended to use by apple, and he first noticed that what I actually had done is somehow converted it to a mbr. any ways, I am on lion, with some of my data saved, and my mac is doing automatic backups every hour using time machine. the only thing I am a bit confused at is why can I not even convert a partition to ntfs on firewire hdd from windows 8 install? do windows 8 dp not support install on external hd? if so, would beta do so? as I really need windows 8 installed as in a actual partition but I want on firewire, am not wanting to touch internal hd!

also, as I am using both lion and snow leopard, every time I want to press alt to chose which bootable partition I want to go to, I have to chose snow leopard as startup disk, as lion gets my mac to not recognise the keyboard until it shows the lion apple logo. so for my mac to recognise it at startup, I got to chose snow leopard as startup disk. A bit annoying, and will be such a pain when got windows on. any ideas?

  lotvic 23:14 04 Dec 2011

"do windows 8 dp not support install on external hd? if so, would beta do so?"

dp = Developers Preview

The Developers home page might have some info. Read the Windows 8 Developer Preview guide http://msdn.microsoft.com/en-us/windows/home/

Best of luck

  Jwbjnwolf 15:09 03 Jan 2012

really looking forward to the beta of win8. Also, am loving 16gb ram in my mac. :)

I am not in any major rush really for putting windows alongside, instead have it back in parallels desktop. will likely put on FireWire when have the final release as then, at least it will be a 32bit and 64bit dvds rather than having to download two massive iso files, 32bit for mine/sisters netbooks and 64bit for my mac. no point wasting my time with that until the final release is out.

  Jwbjnwolf 14:48 02 Mar 2012

I completely LOVE the consumer preview. (what was going to be beta)

It is 2x faster than what the developer preview was on my netbook which blew me over and I LOVE the metro. The metro is what makes me like to use windows again. I love how they have made the task bar not needed as I just auto hide it up the top so it is out the way.

So much better.

But annoyingly when I install parallels tool on it on parallels desktop 7 on my iMac, I can move the pointer around but cant click. :/

But I guess parallels will update soon.

I had a go at seeing if I could install it on my external hdd so I could run it on my mac not in parallels, but because I only downloaded the 32bit and I have 16gb ram in my mac, that is the reason it says "not bootable device found"? Because I guess it is insufficient memory? Not to worry as I can't be bothered to also download the 64bit as net so damn slow! I'll just wait till we buy a family pack of Win8 when it is finally released which will be both 32bit and 64bit dvds

  Jwbjnwolf 16:09 02 Mar 2012
Answer

Right I now have managed to get parallels tools installed Yippi!! Same sort f thing happened with the dp. I couldn't do the parallels tools and then once I came for help, I am able to. damn technology. they sure do have sense of humor don't they?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Fold review: Hands-on

Best Wacom deals for Easter

iMac 21.5in (2019) review

Comment faire pivoter une vidéo ?