PCs connect to router but not internet and mobiles and mac works fine, help?

  uzumaki1107 22:40 01 Aug 2012

Hey guys, this is my first post and would appreciate some help.

Recently I restored my XP to factory settings and soon realised that it wasn't built around WiFi and so had to manually DL SP3 from the website and install it. Around the same sort of time, the whole internet in the house stopped working for everything except my 2012 MBA. This was really weird, computers and mobile devices could connect to the router, BTHomehub-3 but the router couldn't access the internet, all the lights were blue but there was an orange flash beneath the wall unit which indicates an internet problem with BT or something?

The next day or so, mobiles and other things like Sky or my XBOX could connect and browse the internet fine but my two PC computers, one running XP and the other Vista are still having difficulty.

The XP doesn't work with wireless internet of any kind that I've tried; tethering with my HTC, using a Zyxel g-202 (I know its old but i've never needed to replace it!) adapter with drivers installed through the Zyxel software and even on the XP wireless menus.

The Vista seems only to have a problem connecting to the internet when it has to use its own WiFi, by this I mean, when I tethered it via USB or used the hard Ethernet line, the connection was fine. However, when I tried using the inbuilt WiFi function to connect to my BTHomehub or even a personal WiFi hotspot made by mine or my dad's HTCs, it had the same issue of being able to connect to the router but no internet.

Any ideas on how to tackle this enigma?


  [email protected] 22:52 01 Aug 2012

When you say it connects to the router, do you mean you can actually navigate around the router's webpage by going to (or whatever IP address your router has)?

Have you checked all your IP settings are set to automatic? (Go to Control Panel, Network Connections, right click the network adapter, Properties, select Internet Protocol Version 4, Properties).

Have you checked to make sure that MAC address filtering on the router has not been enabled?

  uzumaki1107 23:18 01 Aug 2012

I've just tried that, on my MBA it connects and sends me to the BTHomehub home website but using the inbuilt WiFi on the Vista, it's stuck loading and i'd think it'd be the same upstairs, well actually, typing in the same IP address on my mac and pc, the mac goes through to the homepage but the pc says "safari can't open the page [http://[ipaddress]] because safari can't connect to the server [ipaddress] :/

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Amazon Echo: What’s the best Alexa speaker?

Kano Computer Kit Complete review: A fun DIY 'laptop' that teaches kids to code

Best pro photo editors for Mac 2018

TV & streaming : comment regarder les Jeux olympiques d’hiver 2018 ?