Emachines 420 - optical drive recognition

  [DELETED] 23:10 20 Jun 2006

I have a secondhand Emachines 420 pc which came with a CD R/W drive and a DVD R drive. The DVD drive was damaged and having got it out I eventually got the mobo to recognise the remaining drive by setting the jumper to CS.
I have now bought and installed a new Samsung DVDRW, and I am trying to get the pc to recognise both drives, but it can't spot either of them. I have tried jumper settings of CS on both, and the existing CD R/W set to Master and the DVDRW to Slave, but to no avail.
Is this machine only able to recognise optical drives made for it or have I missed summat obvious eg I need to change a BIOS setting or something physically on the mobo? There is only one ribbon cable for these drives, with two ends, the lower marked 'slave' and teh upper marked 'master'.
Thanks everyone.

  [DELETED] 23:22 20 Jun 2006

Try both drives on their own - perhaps it's been the old CD-RW drive that's the real problem.

  woodchip 23:25 20 Jun 2006

As this may be a old Comp, set to master on end of ribbon other as Slave on middle connection. Now restart and go into BIOS and auto detect the drives

  [DELETED] 21:10 21 Jun 2006

Woodchip, it's a PhoenixBIOS and there doesn't seem to be anywhere that I can set auto-detect on.

It seems, regardless of whether I have 1 or 2 drives attached, that the only combination that works is: either drive (on its own) attached at master end of cable, and jumper set to CS.

I'm missing something obvious here, aren't I? Help!

  [DELETED] 21:54 21 Jun 2006

Faulty cable? - replace it.

Bad connection on cable? - take it off both ends and refit.

One faulty drive that works on it's own, but not with another drive? - try a third drive in combination with each of the other two.

Both drives should in theory work set to Master on either connector, or as Master on the end of a cable when set to Cable select.

Some optical drives (writers in particular) are very fussy when used with certain other drives.

Cable Select ONLY works when used with an 80-wire cable. 40-wire cables do not support Cable Select.

I've also found some optical drives don't seem to like 80-wire cables - I have no idea why.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple