Cannot Print to Windows print queue, IPP Error

  BelfairsAcademy 09:27 19 Apr 2016
Locked

We have a print queue shared from a Windows server and up until 2 weeks ago we had no problems printing to it. Now however we are getting the following error in the cups log on all of our macs IPP client-error-attributes-or-values-not-supported for Get-Jobs.

Even when I add the printer directly to bypass the queue I get the same error in the log. Nothing has changed on the network and everything else is working fine with the printers.

Just wondered if anyone out there has experienced this error before or know how to solve it?

cheers

  Svol 13:35 19 Apr 2016

Check the CUPS error logs which may give you some info relating to the error condition.

Should you need it, info on how to access the CUPS error logs can be found at:-

CUPS Info - click here

  BelfairsAcademy 13:42 19 Apr 2016

I have checked the CUPS error log and that is where i am seeing the error:

IPP client-error-attributes-or-values-not-supported for Get-Jobs

  Svol 16:51 19 Apr 2016

Try enabling CUPS Debugger mode to see if it logs any additional error codes.

Enabling and disabling CUPS debug logging can be accomplished via issuing a cupsctl command in a Terminal session.

To enable CUPS debug logging, enter:- cupsctl --debug-logging

To disable CUPS debug logging, enter:- cupsctl --no-debug-logging

Then restart CUPS. Not sure the exact command to restart which will depend on the version of OS X but may be something like:-

Prior to Mac OS X 10.5, try this command:-

sudo /System/Library/StartupItems/PrintingServices/PrintingServices restart

In Mac OS X 10.5 and later, try this command (it should then relaunch on demand):

sudo launchctl stop org.cups.cupsd

Hope that works and provides some more error detail for you.

  BelfairsAcademy 09:04 20 Apr 2016

Thanks for the reply and the info...I have enabled the debug and get a lot of data...seems to be a couple of things that stand out to me... "No authentication data provided" and "Broken Pipe"...

I have had a search around for these but can't seem to find anything conclusive or that helps me out.

I have added the log below.

[20/Apr/2016:08:51:19 +0100] cupsdSetBusyState: newbusy="Active clients and dirty files", busy="Dirty files" D [20/Apr/2016:08:51:19 +0100] [Client 7174] Read: status=200 D [20/Apr/2016:08:51:19 +0100] [Client 7174] No authentication data provided. D [20/Apr/2016:08:51:19 +0100] [Client 7174] 2.0 Set-Job-Attributes 1 D [20/Apr/2016:08:51:19 +0100] Set-Job-Attributes ipp://localhost/jobs/9 D [20/Apr/2016:08:51:19 +0100] cupsdIsAuthorized: requesting-user-name="mattp" D [20/Apr/2016:08:51:19 +0100] [Job 9] Setting job-hold-until to indefinite D [20/Apr/2016:08:51:19 +0100] cupsdMarkDirty(---J-) D [20/Apr/2016:08:51:19 +0100] cupsdSetBusyState: newbusy="Active clients and dirty files", busy="Active clients and dirty files" D [20/Apr/2016:08:51:19 +0100] Discarding unused job-state-changed event... D [20/Apr/2016:08:51:19 +0100] Discarding unused job-config-changed event... D [20/Apr/2016:08:51:19 +0100] [Client 7174] Returning IPP successful-ok for Set-Job-Attributes (ipp://localhost/jobs/9) from localhost D [20/Apr/2016:08:51:19 +0100] [Client 7174] Content-Length: 75 D [20/Apr/2016:08:51:19 +0100] [Client 7174] cupsdSendHeader: code=200, type="application/ipp", auth_type=0 D [20/Apr/2016:08:51:19 +0100] [Client 7174] con->http=0x7ffe8c04e800 D [20/Apr/2016:08:51:19 +0100] [Client 7174] cupsdWriteClient error=0, used=0, state=HTTPSTATEPOSTSEND, dataencoding=HTTPENCODINGLENGTH, dataremaining=75, response=0x7ffe8bc1bbe0(IPPSTATEDATA), pipepid=0, file=-1 D [20/Apr/2016:08:51:19 +0100] [Client 7174] Writing IPP response, ippstate=IPPSTATE_DATA, old wused=0, new wused=0 D [20/Apr/2016:08:51:19 +0100] [Client 7174] bytes=0, httpstate=0, dataremaining=75 D [20/Apr/2016:08:51:19 +0100] [Client 7174] Flushing write buffer. D [20/Apr/2016:08:51:19 +0100] [Client 7174] New state is HTTPSTATEWAITING D [20/Apr/2016:08:51:19 +0100] [Client 7174] Waiting for request. D [20/Apr/2016:08:51:19 +0100] cupsdSetBusyState: newbusy="Dirty files", busy="Active clients and dirty files" D [20/Apr/2016:08:51:19 +0100] [Client 7174] HTTPSTATEWAITING Closing for error 32 (Broken pipe) D [20/Apr/2016:08:51:19 +0100] [Client 7174] Closing connection. D [20/Apr/2016:08:51:19 +0100] cupsdSetBusyState: newbusy="Dirty files", busy="Dirty files" D [20/Apr/2016:08:51:19 +0100] [Client 7171] HTTPSTATEWAITING Closing for error 32 (Broken pipe) D [20/Apr/2016:08:51:19 +0100] [Client 7171] Closing connection. D [20/Apr/2016:08:51:19 +0100] cupsdSetBusyState: newbusy="Dirty files", busy="Dirty files" D [20/Apr/2016:08:51:19 +0100] [Client 7175] Accepted from localhost (Domain PrinterProxy[3368]) D [20/Apr/2016:08:51:19 +0100] [Client 7175] Waiting for request. D [20/Apr/2016:08:51:19 +0100] [Client 7175] POST /jobs HTTP/1.1 D [20/Apr/2016:08:51:19 +0100] cupsdSetBusyState: newbusy="Active clients and dirty files", busy="Dirty files" D [20/Apr/2016:08:51:19 +0100] [Client 7175] Read: status=200 D [20/Apr/2016:08:51:19 +0100] [Client 7175] No authentication data provided. D [20/Apr/2016:08:51:19 +0100] [Client 7175] 2.0 Cancel-Job 12 D [20/Apr/2016:08:51:19 +0100] Cancel-Job ipp://localhost/jobs/9 D [20/Apr/2016:08:51:19 +0100] cupsdIsAuthorized: requesting-user-name="mattp" D [20/Apr/2016:08:51:19 +0100] [Job 9] time-at-completed=1461138679 D [20/Apr/2016:08:51:19 +0100] Discarding unused job-completed event... I [20/Apr/2016:08:51:19 +0100] [Job 9] Job canceled by \"mattp\" D [20/Apr/2016:08:51:19 +0100] cupsdMarkDirty(---J-)

  Svol 21:37 20 Apr 2016

Have you tried resetting the Printing system on the MAC? If not might be worth a try as per the following instructions link:-

Reset MAC Printer system - click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Oppo A9 2020 Review

Procreate 5 launches with the world’s biggest brush library – hands-on and specs for the 2019 update

Best Apple tech gifts for Christmas 2019

Noël (2019) : idées cadeaux & guide d'achat !