WLAN AutoConfig has stopped working

  ah1802 18:09 15 May 2007
Locked

i keep getting this error message up:

WLAN AutoConfig has stopped working

just wondering if anyone else is having this problem and is there a way of stopping this message coming up.

adam

  Forum Editor 07:39 16 May 2007

1. Click the start button

2. In the 'Search' box at the bottom type: cmd and press the enter button.

3. At the command prompt type: netsh and press enter.

4. Now type: wlan and press enter

5. Now type this: set autoconfig enabled=yes interface="Wireless Network Adapter" and press enter.


By default, Vista enables the WLAN AutoConfig, so that your computer's wireless network adapter will automatically recognise and offer any wireless network within range. For some reason your Vista installation is telling you that it has disabled the facility.

  Babrow 20:01 28 Jul 2007

I would like to know if the suggestion above by the Forum Editor worked for fixing the original poster's problem with their WLAN AutoConfig. I have a fairly new (5 months) Dell Inspiron 9400/E1705 running Vista Business 32-bit OS. I have similar issue in that Dell Warranty Support folks have presumably finally diagnosed that the reason my WLAN connection no longer works is because something happened with the WLAN AutoConfig DLL file and they are suggesting a full re-installation of Vista (they are also offering to allow me to get XP installed instead since I have had numerous other problems with Vista, but that is another issue). Either way, I would like to find a fix to the mere problem I have with the WLAN AutoConfig and not reinstall operating software at this point because so many things were wrong with the Vista OS when I got it to begin with that I don't want to fix everything over again from square 1. Everything was running just fine until this WLAN problem came up, which I suspect arose because I was on vacation and might have had some settings for network connections get adjusted (unintentionally) when I used someone else's home Comcast cable modem and then a Wayport bridge at one of the hotels I was staying at when I couldn't get their WiFi network simply through my computer's card. I have already changed out the WLAN mini-card hardware in trying to work this problem with Dell, so we don't think that the hardware is really the issue, even though a set of diagnostic tests run on through the Intel utility seem to indicate so (diagnostics also show software issues). Any suggestions? I'm fed up with the Dell support I've gotten so far.

  jasjas 10:32 17 Aug 2007

I've had the same problem. I've been searching on the net and gathering info from different places i have made it work!! I have followed this steps:

1) Click on “Start”
2) Right click on “Command prompt” and choose “Run as administrator”
3) Click on “continue”
4) Type netsh
5) Type wlan
6) Type set autoconfig enabled=yes interface=”Wireless Network Connection”
7) You will se a message informing you that it has correctly been enabled.
8) Type exit
9) Type exit

Regards,
JASJAS

  MOTguitarist 03:54 21 Apr 2008

So I'm not that great with computers but ive so far understood all of this, and tried what you guys suggested. I got a message after typing "set autoconfig enabled..." that says "The Wireless AutoConfig Service (wlansvc) is not running."
Any ideas on how to get it running or solve that problem?

  callumfarrimond 22:38 12 Jun 2009

run. type cmd and press enter.then hold down control-shift and press enter. this will you put in administrative mode. the next command is sfc/scannow and enter. this will take around ten minutes. when this has finished go to computer right click and click manage. then go to services and turn on wlan, which at this point says "stopped". the previous will have fixed the error message you get when ever you try and turn it on.

  gauthierD 12:00 18 Jun 2009

Hi

thanks a lot callumfarrimond, it worked for me
=)
just a thing, could you explain why it worked, what was wrong with that and so on ?
it would be awesome !

thanks again anyway.

  rb1959 01:30 29 Jan 2010

I tried all the fixes here including the sfc\scannow and thank you to everyone on this thread for their great advice. Unfortunately the result of the command was the following: "Wireless Resource Protection found corrupt files but was unable to fix some of them. Details are in the CBS.Log windir\logs\cbs\CBS.Log For example: c:\Windows\Logs\CBS\CBS.Log" I am now so tired of this WLAN auto-config Wireless Service that will not restart, I am ready to do something like bag vista and move on to another op sys. Does that make the most sense? Even the drivers and utilities disk will not re-install the WLAN software because it says "Dell Wireless 1515 Adapter Device not found." What nuttiness. The computer is an Inspiron 1545 only 4 months old. Wireless was working fine up until now.

  tullie 08:23 01 Feb 2010

This thread is three years old better starting a fresh one of your own

  rb1959 15:09 04 Feb 2010

Thanks Tullie. I did just that. In my frustration I just did not pay attention to the dates.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

What is ransomware and how do I protect my PC from Petya?

Microsoft Surface Studio – the artist's hands-on review

Original iPhone review

Comment mettre à jour Kodi ?