Wireless optical mouse will not work

  Florio 09:37 01 Jan 2008

I have an Acer Aspire 5105 laptop with Vista SP1 as the OS. Yesterday I bought a wireless optical mouse (Trust, MI-4920NP mini mouse) so that my young son could play some games on the compute without having to use the touchpad.
When I inserted the USB connection, I was informed that the device was installed correctly, but the pointer does not respond at all to the movements of the mouse, and the touchpad remains the only means of moving the cursor.
I've tried inserting the USB plug into other USB ports, but the result is always the same.
I know that similar problems have appeared on the Vista forum in the past, but I've been unable to see how they were resolved.

  Ashrich 09:58 01 Jan 2008

Have you paired the adapter with the mouse ? Usually by pressing the button under the mouse and through software for USB adapter .


  aine 14:00 01 Jan 2008

I think you will find that you have to go control panel, select mouse, change option to mouse instead of touchpad. Hope this helps

  Florio 19:19 01 Jan 2008

Thanks Ashley and Aine. Yes, I had already done as you suggested before posting. I should say, however, that when I go to Mouse in the Control Panel, the Trust optical wireless is not listed, only the touchpad. Is this normal? Is it worth taking the mouse back to the store tomorrow to get it changed, or do you think the problem would still exist?

  Ashrich 19:43 01 Jan 2008

Plug it all back in again , let it finish loading the drivers , then have a look in Device Manager to see if an HID device is listed , also , did Vista SP1 come loaded on the laptop , or have you loaded it yourself ? As it is only a release candidate it might not be fully finished .


  Ashrich 19:54 01 Jan 2008

Trust have a latest drivers on their website , although it is supposed to correct a scroll issue it might be wise to download and run it to see if it makes a difference , for the Vista driver click here .The site also details pressing the buttons on the USB dongle as well as the mouse , had you done that ?


  DerekR 23:34 01 Jan 2008

There may be a small additional button on the base of the mouse that says "connect" - usually hard to see - I had this same problem until I pressed it with a small needle

  DerekR 23:35 01 Jan 2008

* an additional button to the pairing button Ashrich mentioned further up the thread

  Florio 08:41 02 Jan 2008

I've plugged everything back in again, with mixed results; now the mouse menu of the control panel lists the HID device, but there seems to be no way of choosing to use the mouse rather than the touchpad. Pressing the buttons on the mouse and USB dongle doesn't change anything, nor does the installation of the drivers (which I had already done -- forgot to tell you that!).
As for the Vista SP1, it was downloaded automatically once I had established an internet connection (the computer did come with a CD or Vista updates which I have not installed). Do you think the problem lies here?

  Florio 19:33 02 Jan 2008

Problem resolved, guys. I took the mouse back to the store, and a sales assistant there tried it out using one of the computers on display. I was told that you have to press the button on the USB dongle first, and then while the light on the dongle is still flashing, you have to press the pairing button on the mouse itself. Just a question of synchronisation, I guess. My mouse is now working perfectly. With a bit more attention to detail, surely the accompanying instructions could have been a bit more useful!! Thanks again for your suggestions.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache