Windows 7 weird problem

  DoobiePayne 19:04 26 May 2014
Locked

Windows 7 ultimate I5 processor Connected to modem/router via linksys switch

When I start any browser, I can go to google and get web search results, but when I click on them I get page cannot be displayed.

If I ping my router it's fine, good speed like 4ms

If I ping an external IP address it's fine like 32ms

If I ping an external name, like BBC.co.uk it fails completely

Ih ave another switch that works fine with all internet actions, and we changed them over, but I get the same results

The computer is set to obtain IP address automatically and it gets one fine each reboot

If I start the pc in safe mode, all web pages display ok...........

Any help would be appreciated

  DoobiePayne 20:13 26 May 2014

A bit of an update.

Ping google.co.uk works fine

Ping 8.8.8.8 works fine

Ping avg.com ping request could not find host

Ping sony.com works fine

Www.sony.com works fine in a browser

This is so frustrating

  DoobiePayne 21:40 26 May 2014

I have updated the Qualcomm killer networks driver and this has not helped.

BBC.co.uk will not load in a browser Itv.com will not load Channel4.com will Channel5.com will

How do you start to fix a problem that is random, yet constant

  Secret-Squirrel 09:58 27 May 2014

It sounds like something's interfering with your DNS when the PC is running in Normal mode. Try this:

Open a Command Prompt window and type nslookup - what IP address do you get in the "Address" section.

I'll see if I can come up with some practical advice once I get your reply.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?