windows 7. service pack 1

  grizzley 17:13 23 Mar 2011

i recently downloaded service pack 1, it installed then on restart it stopped starting up. i had to forcibly shut it down, and used last known good configuration and start-up repair. systems starts normally now, but without service pack installed. anyone got any ideas on how to fix this problem. service pack 1 is back in update section but i refuse to download.

windows 7 home premium, installed over vista home basic.


  chub_tor 17:27 23 Mar 2011

Take a look at Microsoft's recommmendations click here before you try the update again.

  grizzley 20:43 23 Mar 2011

I followed advice from chub-tor.

I ran troubleshooter to fix update problems.

I downloaded service pack 1 again, retsrted and it got passed log-on logo before locking up.

Had to force shutdown and ran update repair, it then asked if i wanted to restore to a previous time, i chose this option. System works fine without servic epack installed. This 3rd attempt to get service pack 1 installed and on each occassion it failed. I have had enough of trying to get service pack 1 to install without any problems. My system is virus free, and no known spyware/malware is on computer according to windows defender.

  Ankermi31 17:21 27 Mar 2011

Had hardly any problems. Did my own restore point first off before starting the task.

Started download went ok but very slowly.

Started to install and it froze so used the Microsoft troubleshooter. This allowed me to continue with no problems albeit slowly.

In total it took me over 75 minutes start to finish.

  2bathblack 23:32 27 Mar 2011

When I updated mine,(Win7 over Vista) I thought it had frozen but from previous experience knew that sometimes an install program/OS will appear to do nothing for long periods. The trick is to be patient and go for a walk or make lots of tea, I read most of a novel waiting for SP1 to install.

  grizzley 15:24 28 Mar 2011

Thanks for advice appreciated.

I have tried several times to install, but each time my system fails to start and i have to forcibly shut down. Servic epack 1 was over 93meg in size, but that is nothing new. I have done a re-install of vista over weekend. I may try windows 7 again sometime, but will leave it for now, my system works ok. may not have enough memory for win 7. I have 1024MB memory, with a 120 GB hard disk, running vista home basic. It was only win 7 service pack that caused problem.

  keith mac 16:26 12 Apr 2011

Is there anything in SP1 that routine MS updates won't already have installed?

  Seadog 22:56 12 Apr 2011


I had exactly the same problem yesterday. I updated win 7 to SP1 on both my laptop (which went ok no bother) and my desktop pc which just wouldn't do it!

Eventually got it to install after downloading this 'System Update Readiness Tool', and disabling my anti-virus. My pc still wouldn't install SP1 even after installing the SURT until I switched McAfee Total Protection off, but then the install instructions do say to turn AV off................

  grizzley 13:08 16 Apr 2011

I have installed service pack 1 again, but problem started again. My problem seems to be on start up, once all security updates are installed, then service pack 1 installed, on start up it would not do anything, had to forcibly shut it down, and use start up repair, that failed so had to use restore point to get my system to start. I have read that, installing windows 7 on top of vista is ok. I do not know why this keeps happening. I installed windows 7, installed my anti-virus. but even stopping avast does not help. Anyone got anymore ideas. Help would be appreciated.

  Seadog 13:35 16 Apr 2011

You don't mention it but have you downloaded and installed the 'System Update Readiness Tool' from Microsoft that I mentioned in my earlier post and tried it again?

I honestly recommend you do this next - there are several posts on other forums with people having the same freeze on start-up problem as you and they all seem to be sorted after installing the SURT.

  grizzley 21:53 16 Apr 2011

Thanks for advice. I ran SURT, which advised a hotfix install. I did the install and tried again, i still have same problem, computer will not start up and start up repair can not fix. I have noticed during configuring service pack 1 on shutdown, it gets to 30% and then shuts down, on restart it try's but fails to start . I am at a loss for reasons for this. on one occassion i ran startup repair, i got a failure notice . system files check and repair, result: failed error code = 0xa.

I might has well re-install vista basic. I can not install win 7 service pack 1. I might inform microsoft of this problem. but it may turn out my computer is at fault.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?