Windows 7 advice for boosting Ram

  bpzoom 09:56 08 Jan 2012
Locked
Answered

The flyer that came with this month's PCA included a tip to utilise a blank USB flash drive for virtual memory. When I go to Properties/ReadyBoost on the USB drive, it says "This device cannot be used by ReadyBoost" Then it says "ReadyBoost is not enabled because the service responsible for ReadyBoost (Sysmain) has been turned off on this computer. An administrator can turn the Sysmain service back on" When I searched, including Microsoft website, there is no recognition of the term Sysmain. Can anyone please advise. Windows 7 64 bit Dell PC

  chub_tor 10:14 08 Jan 2012

Microsoft Answers Click Here

  difarn 12:05 08 Jan 2012

This can happen if tweaks have been made to change the start-up procedure.

Very similar to the advice in the above article but may be simpler to follow:-

click on Start and type in services Right-click the Services item with the cog/gear icon next to it and run as administrator.

Scroll down to Superfetch. Right-click > properties > Startup type: Automatic > Apply > OK

Go back to the command prompt and type net start sysmain. The service should start successfully.

  bpzoom 13:10 08 Jan 2012

Thank you both. Unfortunately, following your paths both solutions, the startup type is already switched to automatic. For some reason the sysmain system will not operate.

  difarn 13:39 08 Jan 2012

Did you try a registry "fix" - see article attached.

I am wondering if you have missing or damaged system files? Have a look at this article in respect of ready boost.

  bpzoom 15:47 08 Jan 2012

I have gone through the two routes sfc /scannow, nothing found, and I have edited the registry to give permission over Sysmain to owner user. I already have it as administrator, no effect, it still will not work. I have changed the flash drive for another, same result.

  difarn 16:45 08 Jan 2012

When you tried to enable superfetch did you see anywhere where you could "Turn off the option "Tune Windows for speed" in the "Optimization" to enable superfetch"

  difarn 16:52 08 Jan 2012
Answer

Just come across this in a very large blog:-

"I have had the same problem with ready boost. I copied everything in the C:\Windows\Prefetch folder into a new folder on my desktop, then deleted everything in the C:\Windows\Prefetch folder. rebooted and Ready boost is now working on my machine."

  bpzoom 22:04 08 Jan 2012

difarn, Brilliant, thank you! That blog advice worked a treat. I have no idea why but there it is working on the flash drive. Thanks again and to the others who have replied.

  difarn 06:50 09 Jan 2012

Excellent news - glad to have been able to help - have learned something along the way too.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone