Windows 10 no internet trough Ethernet

  TheSandman225 16:29 13 Aug 2015
Locked
Answered

So ever since I upgraded to windows 10 my Ethernet cable connection drops after 10-20 min. It will work again after a reboot but will drop after a few minutes. I still have internet trough WiFi.

Some information about my internet setup My desktop is connected to the internet trough a Ethernet cable. this cable feeds into a switch which is connected to a modem. I also have a router that is connected to the switch. And right now I am connected to the router trough WiFi.

So far i have tried:

  • restarting modem
  • using different Ethernet cables
  • connecting to the router instead of the modem (with Ethernet)
  • Let windows look for a solution. Didn't do much but tell me that there was no default gateway.
  • Tried uninstalling the Ethernet driver. The uninstall never finished the progress bad just kept looping. (still need to try again)
  • A forum online had said to uninstall virus protection and reinstall it after reboot. Didn't work.

I don't really know what else I could do. It is really starting to frustrate. I really hope someone knows what to do. I am tempted to go back to windows 8.1 just so that this problem won't exist anymore.

  RegScriv 21:10 13 Aug 2015

Can't give you a solution TheSandman225 but I have the same problem, after using my browser(Chrome) for a period it disconnects from the Internet and the only way I can get it back is to re-start my pc. I tried many of the things that you have, including un-installing my ethernet adaptor and letting Windows re-install it on re-start. That left me worse off. I then had a permanent block on my broadband that I couldn't overcome. I had to use a disc image(Macrium Reflect) to take me back a few days. Incidentally, System Restore didn't work properly, gave me my shutdown problem. I think MS need to do some serious improvements to W10, it's not stable. I've had other problems such as my pc won't shut down.

  TheSandman225 21:14 13 Aug 2015

I may have some shutdown issues after my failed attempt at reinstalling. Don't know how good the odds are of this getting fixed in an update. Might end up reverting back to windows 8.

  TheSandman225 21:59 13 Aug 2015

I did some looking around in the properties of the Ethernet connection. It seems that for some reason I am no longer connected to Ipv4 and ipv6. Could this be a problem being caused by my firewall? At the moment my only firewall is windows firewall.

What i have also noticed now is that in the adapter settings my Ethernet connection is "disabled" when I try to enable it it shows a box with enabling. After that it tells me that it is enabled. But that doesn't happen. The Ethernet connection remains grey

  RegScriv 09:56 14 Aug 2015

Your ethernet issues are exactly the same as mine. Luckily I had taken a Macrium Reflect image of my disc, which I re-instated and got a working system back. Might be worth re-installing W10. I'm on the brink of reverting back to W8.1. I have an intermittent shutdown problem, it won't shut down or sleep. It will shut down or go into sleep then immediately re-starts. It's not doing it right now but I'm expecting it to start again soon. If I revert, I'll wait at least 6 months before I try again.

  TheSandman225 00:00 15 Aug 2015

I think I may have solved my problems. Will need to see if it still works tomorrow morning. But so far I have had an Ethernet connection for over an hour which was not possible before this. My PC now also powers down when i shut it down. I no longer have to manually turn it off.

So here is what I think solved my problem. After finding out I still had some problems in windows 8.1 I decided to go back to windows 10. I was unable to preform a full reinstall of windows so i opted for the system reset option.(I don't think this step is 100% necessary but it is one of the things i did to get to this point)Sadly after the reset I still had the Ethernet problem and shutdown problems. At this point I gave up and decided that I would try to reinstall my Ethernet adapter again. I figured it couldn't cause anymore problems and I was thinking about doing a clean install anyway. So I went to the device manager and selected the adapter. In the properties in the section drivers I selected uninstall. This instantly removed my adapter from the list of devices. After that i scanned for hardware changes and it came back. I then proceeded to test my internet. It didn't disconnect and when I shut down my PC it powered itself down.

Will check in tomorrow to see if everything still works I am going to sleep now cause I am so done with this crap.

tldr. I ended up reinstalling my Ethernet adapter drivers. Not sure if that fixed it permanently

  TheSandman225 06:57 15 Aug 2015

Well that did not work. I ges it was not enough to reinstall the Ethernet adapter. After starting up this morning I immediately lost Ethernet connection.

  TheSandman225 15:54 16 Aug 2015
Answer

Okay now i think i found the solution. So far the Ethernet cable has been working for 3 hours now. The problem was most likely the version of my drivers. My Ethernet adapter still had the drivers installed from when I got my PC. That was 6 years ago. So these drivers where made for windows 7. (My Ethernet adapter is Broadcom Netlink (TM) Gigabit Ethernet.) It still had driver version 15.2.0.0 or something. After some hard searching I found the newest drivers for my card. 17.2.0.0. After downloading and trying to install it trough the device manager is told me the best drivers had already been installed. So to be safe I rebooted my pc in safe mode. Put the drivers on a usb and did the following.

Before I installed the new drivers I searched the control panel for Change device installation settings. In the that menu I disabled device installations trough windows update. I did this as a precaution cause I believed that the drivers might get reverted by the windows updates.

In the device menu I selected update driver. I then selected browse my computer for software. I then selected "let me pick from a list of device drivers on my computer". After that a new window opened with compatible hardware. I then selected have disc on proceeded to search trough my usb for the driver files i wanted to install. Then the list of compatible hardware expands. I selected the right one and pressed next. After the install completed i checked and saw that the driver version had been updated to 17.2.0.0. Booting back in normal mode I found that my Ethernet adapter was now still working after 3 hours. (the install warned me that the windows did not know if my hardware supported this driver and that installing could cause problems. So I guess you should do this at your won risk. it worked for me but might not work for you)

  Billion007 08:01 16 Sep 2015

Thanx Sandman225 ... It worked. The Change device installation settings step I think is important as you mentioned...

  azitalian 18:13 04 Oct 2015

Hey all...this happened to me as well. I have a Cisco Gatewaway (modem + router) and my laptop could connect to the internet wirelessly, but my desktop could not through the ethernet. I had intermittent problems after upgrading to Win 10 from 8.1...noticeably when I "restarted" as opposed to "shut down" and turn on--with a restart, it wouldn't connect via ethernet until I shut down and turned back on.

This morning, it just wouldn't connect to the internet no matter what I did...but laptop had wireless internet. So I called Cox Communications, wondering if it was the Cisco Gateway. Long story short, through many resets and other troubleshooting, what fixed it was this:

  1. Right click Window button
  2. Select "Command Prompt (Admin)"
  3. Type the following: netsh winsock reset
  4. Press enter button.
  5. Response will tell you to reboot computer.
  6. Reboot
  7. Fixed!

Hope that helps someone else.

  gamerx 19:20 11 Oct 2015

Thanks TheSandman225!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone