Vista ultimate 32bit 4gb dual channel bsod

  kyah86 21:36 29 Jan 2009
Locked

Hello, I am experiencing constant bsods on startups using windows vista ultimate 32 bit, but ONLY when running my 4 gigs of ram in dual channel. Running any lower quantity is out of question since 2gigs are not enough for me and 3gigs disable dual channel which slows me down way too much. I use asus striker extreme (680i) mobo and Q6600 with 280 gtx gpu.
1) RAM fully tested with memtest and prime95- it's 100% fine.
2) The problem appeared only once I upgraded from xp to vista. Thus, I guess it's a OS issue.
3) Tried all possible memory timings/voltages.
4) Like I said, bsods happen when I run the 4 gigs in DUAL CHANNEL ONLY. However, if I don't, they are just plain slow :(

Dunno if I have space to post my kernel dump here, but here it goes:


BugCheck A, {72cffff6, 2, 0, 81caa4c5}

Probably caused by : memory_corruption ( nt!MiUnlinkFreeOrZeroedPage+15 )

IRQL_NOT_LESS_OR_EQUAL (a)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arguments:
Arg1: 72cffff6, memory referenced
Arg2: 00000002, IRQL
Arg3: 00000000, bitfield :
bit 0 : value 0 = read operation, 1 = write operation
bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: 81caa4c5, address which referenced memory

Debugging Details:
------------------


READ_ADDRESS: 72cffff6

CURRENT_IRQL: 2

FAULTING_IP:
nt!MiUnlinkFreeOrZeroedPage+15
81caa4c5 0fb6460e movzx eax,byte ptr [esi+0Eh]

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

BUGCHECK_STR: 0xA

PROCESS_NAME: System

TRAP_FRAME: 8d717bf0 -- (.trap 0xffffffff8d717bf0)
ErrCode = 00000002
eax=80cf3000 ebx=92081000 ecx=00000400 edx=00000000 esi=80cf2000 edi=92081000
eip=81c9dd13 esp=8d717c64 ebp=8d717c6c iopl=0 nv up ei pl nz ac po nc
cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00210212
nt!memcpy+0x33:
81c9dd13 f3a5 rep movs dword ptr es:[edi],dword ptr [esi]
Resetting default scope

LAST_CONTROL_TRANSFER: from 81caa4c5 to 81c8ec84

STACK_TEXT:
8d7179d0 81caa4c5 badb0d00 00000000 00000000 nt!KiTrap0E+0x2ac
8d717a54 81caafc6 ff55ffff 000002ec 81d42220 nt!MiUnlinkFreeOrZeroedPage+0x15
8d717a84 81cbe74c 000002ec 86a14030 c0248204 nt!MiRemoveAnyPage+0xa9
8d717abc 81caf62e 00000001 92081000 c0248204 nt!MiResolveDemandZeroFault+0x411
8d717b68 81ca580e 92081000 00000000 00000000 nt!MiDispatchFault+0x9a6
8d717bd8 81c8eab4 00000001 92081000 00000000 nt!MmAccessFault+0xdca
8d717bd8 81c9dd13 00000001 92081000 00000000 nt!KiTrap0E+0xdc
8d717c6c 81d7b586 92081000 80cf2000 00001000 nt!memcpy+0x33
8d717c94 81d7bb70 8b026008 00000000 86a14030 nt!HvpDropPagedBins+0x86
8d717d7c 81ddc6d5 00000003 76d12ede 00000000 nt!CmpLoadHiveThread+0x351
8d717dc0 81cc36de 81d7b81e 00000003 00000000 nt!PspSystemThreadStartup+0x9d
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


STACK_COMMAND: kb

FOLLOWUP_IP:
nt!MiUnlinkFreeOrZeroedPage+15
81caa4c5 0fb6460e movzx eax,byte ptr [esi+0Eh]

SYMBOL_STACK_INDEX: 1

SYMBOL_NAME: nt!MiUnlinkFreeOrZeroedPage+15

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: nt

DEBUG_FLR_IMAGE_TIMESTAMP: 48d1b7e8

IMAGE_NAME: memory_corruption

FAILURE_BUCKET_ID: 0xA_nt!MiUnlinkFreeOrZeroedPage+15

BUCKET_ID: 0xA_nt!MiUnlinkFreeOrZeroedPage+15

Followup: MachineOwner

  Pine Man 11:50 30 Jan 2009

I am assuming that you have four slots for your RAM.

When you use 2X1GB RAM is Dual Channel enabled and your PC ok?

On the basis that it is have you tried various lots of 2X1GB RAM in different slots to make sure it all works at that level in Dual Channel?

  crosstrainer 16:25 30 Jan 2009

Check your BIOS screen (you might just see it on boot up if you look carefully) and find out what device is using IRQ 2.

Can also look in device manager, going through each device by right clicking it and choosing properties.

When you find the device, post back, that's where your problem lies.

I have also seen this occur with poor quality memory, even though memtest reports it as ok.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017