Vista Sidebar often doesn't work

  Pineman100 12:13 18 Aug 2007
Locked

We bought a new Vista Home Premium laptop about a month ago. The Sidebar is set to start when Windows starts.

However, I reckon that about 20% of the time, Windows boots up OK, then we get a report saying "Windows Sidebar is not working". If you then restart the computer, the Sidebar usually works.

The only gadgets running are the clock, calendar and contacts.

Anyone else had this problem? Did you manage to solve it?

  Forum Editor 12:33 18 Aug 2007

1. Open a command prompt by going to Start/all programs/accessories/ and right clicking on the icon - select 'run as administrator.

2. When the command window opens type:

regsvr32 scrrun.dll

and press the enter key

3. Now type

regsvr32 jscript.dll

and press the enter key

4. Now type

regsvr32 msxml3.dll

and press the enter key.


Now restart your machine, and come back here if the sidebar doesn't load.

  Pineman100 17:26 18 Aug 2007

I've done as you suggested. At each of the three stages, I received a ".....succeeded" report.

I restarted and the Sidebar opened fine - but then it mostly does! It's just that pesky 20% of the time that it's a problem.

However, I'm hoping that it now will settle down and run properly every time.

I'll try and remember to revisit this thread in a few days and report.

Many thanks again for your help.

  Pineman100 19:01 21 Aug 2007

We've tried Vista for a few days after your recommendations. Sorry to say the procedure doesn't seem to have made any difference.

The Sidebar still seems to make up its own mind whether it's going to work or not.

Do you have any other suggestions, please?

  anskyber 19:08 21 Aug 2007

The side bar has been known to have some lack of compatibility with other installed software. The trouble is finding which, even assuming it's your problem.

I suggest you try removing one element at a time and seeing how it goes. The one I would remove first is Contacts.

  anskyber 19:14 21 Aug 2007

Also try the solution here which has worked for some. click here

  Pineman100 19:15 21 Aug 2007

Contacts is the most useful gadget of all! If that has to go, then I think we'd rather live with the problem. :-(

  Pineman100 19:20 21 Aug 2007

The solution on that Vista forum seems to be the same one that FE suggested above.

But thank you for your ideas.

  anskyber 19:23 21 Aug 2007

They are different commands to the ones suggested by the FE.

  Pineman100 19:26 21 Aug 2007

Looking at it again, you're right. Sorry! I'll give it a try.

  setecio 16:04 01 Sep 2007

Anyone else have this problem ... I do

Anyone found a working solution ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?