Vista Ethernet connection problem

  didean 22:46 17 Aug 2007

Hello there, I have a functioning broadband connection on my pc, running XP. I bought a Vista Acer 5051 laptop recently and a couple of weeks ago could access the internet from it with no problems. However,two weeks later, for some reason now it doesn't work. The only changes I have made is to install a firewall, update MS updates and connect using the "auto" connect function to get a wireless connection at a friends house. I have now turned off the firewall, to no result. I have done a sytem restore to no result.
Does anyone have any suggestions?
When I do IPconfig, it shows WLAN media disconnected (to be expected as the the modem I am trying to connect with is an ADSL modem, not a wireless one, then shows the IP address to be The IP address of my working pc XP is
Does anyone have any suggestions that may help?

  lil27 08:31 18 Aug 2007

Not an expert by any means but when you get the cannot connect pop up, have you tried diagnose problem ?


  daxian 10:25 18 Aug 2007

hi didean......
how do you connect to the modem ?
usb or ethernet cable ?
is the modem also a router ?(can you have both pc & laptop connected at the same time).Dave.

  didean 12:30 18 Aug 2007

in response to Lil
when I run diagnosis, its says remote server is not responding or that the firewall of remote server is blocking

  didean 12:32 18 Aug 2007

Hello daxian

I use an ethernet cable to both pc and laptop. One connection works, the other doesnt any more.

  daxian 17:39 18 Aug 2007

hi again ....
have you tried the cable for the pc in the laptop.?
looking to eliminate the cable as the cause of the problem....
does vista report cable unplugged even though it is plugged in ?
if you switch off the wireless can you see the local network connection in network connections,
im thinking that the wireless lan is overideing the cable connection or the cable is damaged .Dave

  didean 21:04 18 Aug 2007

Hi daxian
Yes I have tried a different ethernet cable, and the original cable also works for my other pc, so I don't think that's it.
I tend to agree with you, its definitely a software problem. Could be possibly the automatic WLan stopping the ethernet connection. Do you know how I stop this? or change this?

  daxian 21:43 18 Aug 2007

hi didean......
i think its more than possible the wireless has taken the same ip addy as the network card ...
switch off the wireless lan, connect the ethernet cable.....
then using the run command do an ipconfig /release,then ipconfig /renew,pressing return after each command......that should do the trick ..Dave

  didean 06:52 19 Aug 2007

forgive me but how do I turn this off? By deleting it in Network connections? or by ensuring the switch is definitely off? I m new to wireless laptops.

  Ashrich 15:12 19 Aug 2007

Should be a switch or key combination to toggle wireless on and off .


  didean 18:13 19 Aug 2007

Hello there
when I tried to run the command above, I got a system message;
"The requested operation requires elevation"

I then tried to go to the root directory to run the same command with the same message being produced.

Can any one explain what this means?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?