USB flash drive is write protected

  dantanito 17:57 29 Mar 2014
Locked

Hello I have a USB flash drive (JetFlash Transcend 8 GP) that has its file system changed to RAW and is not readable anymore. When I try to format the device an error occurs because it is "write protected" and the format is not possible. I have another flash drive that works fine on the same computer (PC running on W7) and the problem is only with this one. I have already tried the registry editor method,command prompt,command prompt in safe mode,low level format,the device has no switch on it,has not been physically traumatized,has not suffered power outages,write caching is disabled so no problem from safe removal(I used to remove it safely anyway),it is recognized by my PC and designated by its full name plus the little blue light lead me to think it is not corrupt,I also used testdisk to retrieve all files stored on the device and it was successful,it was purchased a year ago.

My question is this: Is there any other way to try and remove write protection from this device?

  rdave13 18:45 29 Mar 2014

Try the HP USB Disk formatting tool, click here. Use the small green download link with Free version (2 MB) on it. The others are ads!

  BRYNIT 18:51 29 Mar 2014

Have you been to the Jetflash website and tried there own program CLICK HERE this should repair any problems or if you click on the download wizard it will direct you to their own format tool.

  BRYNIT 18:53 29 Mar 2014

I should have said the click on the download wizard box towards the left it will direct you to their own format tool.

  dantanito 21:46 29 Mar 2014

Thank you I tried both suggestions but unfortunately it still didn't work. It turns out the device is corrupt otherwise one of these attempts would have worked by now. Anyway thank you very much.

  rdave13 23:26 29 Mar 2014

Go back to disk management (flash drive connected) and try to delete the volume. Accept the warning. Make sure you delete the flash drive and no other.

Remove the drive and reboot. Once rebooted to desktop connect the drive and see what Windows says.

  dantanito 04:51 30 Mar 2014

I think the drive is corrupt because even that doesn't work but I learned a lot about formatting drives and retrieving information and your help is much appreciated.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?