USB Controllers not found Windows 7

  Dukeofkenpas 13:08 26 Oct 2009

Upgraded from XP (using easy file transfer)to windows 7. Nothing on USB ports works. Device Mgr shows all eight USB Root Hubs have a yellow mark against them and Windows advises drivers are latest. However Device manager says drivers not installed code 39
I have tried disabling, uninstalling (inc Safe mode)and Windows picks them up on reboot but all fail again.
Via site does not address the issue and contacting them just refers one to the site.
Bios is Phoenix Award. Motherboard AsusPV5D2-MX.
Chipset VIA P4M890 + VT8237A
I had expected Windows just to pick the USB hubs up but as it stands none of my peripherals on 8 ubs hubs will work. I have withdrawn all tiems and reinput in different slots but no joy
Help please!

  a member 13:47 26 Oct 2009

I would look up your motherboard details and visit the makers website and download the drivers from there ,put them on your desktop and right click the file and select run in compatability mode for ,and select (for example windows XP) .this should get them up and running .
Have you updated windows via windows update yet ,I would have thought you would have found some drivers that way .

PS: 32bit or 64.

  Dukeofkenpas 23:40 26 Oct 2009

Thanks merlinx.
32 bit. Easier said than done. I found one reference to the chipboard and downloaded it as an XP file. It came as a zip file which I extracted. It gave me one binary file (.bin) which I have no idea how to deal with.
I am seriously thinking of going back to XP!
PS Yes I have used Windows update

  Dukeofkenpas 15:40 27 Oct 2009

Found out how to open the bin file but the procedure did not work. Probably because it required a uSB stick (which I cannot use for obvious reasons) or a floppy disk drive which i do not have. I tried burning to a cd and dvd but in reboot sequence the programme facility came up but did not show the file. I have spent so much time on this that I am on the verge of giving up (and probably going back to pencil and paper!)

  Technocrate 09:07 23 Apr 2010

I can confirm this solution. I had the same problem and I turned off the computer, unplugged the power cable then plugged everything back in and restarted and the error message was gone. Finally!!! No more "Unknown USB Devicemessages."

  Dukeofkenpas 23:30 25 Apr 2010

Thanks for this although problem now solved. I found that a new DVD drive solved a lot of problems including the installation of Windows 7 and the subsequent satisfactory operation of all USB ports

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Les meilleures enceintes Bluetooth à moins de 150 euros