Unable to use network printer.

  grabster 19:28 10 Apr 2007

Hi, I am not able to print from the wifes Vista home premium lappy which is networked ok otherwise with the main desktop pc running xp home.
The printer,Epson r300 , doesnt have a vista driver and the xp one doesnt work.I have followed vita's walkthrough to try and add the printer but it goes belly up when it cant update the driver and according to epson there aint gonna be any updates released.
Is anyone using a similar setup successfully that could enlighten me i wonder ?

  HappyTrucker 05:43 11 Apr 2007

As for the Vista driver for the R300, it should work no problem. According to the Epson website, the R300 driver is (should be) embedded within Vista.

I have an XP laptop, Desktop and a Vista desktop. All are networked together and can share files (with the occasional fit thrown by Vista). Now my printer is an R200, but like yours the driver is described as 'in-box' or part of Vista. I have my printer attached to a wireless print server (Netgear WGPS606) but I can print from all PCs.

Since I get the impression that your printer is connected directly to the XP desktop PC, have you set the printer to be shared on the network? Right click the Printer and in Properties, set the sharing option if you haven't already done so.

Before you do anything else, I would unplug the USB for the printer from the XP PC, and just plug it into the laptop. Vista SHOULD install the driver for it automatically (although Status Monitor - ink levels - doesn't seem to have made the Vista switch). At the very least you'll know the printer works under Vista.

If no-one else comes up with anything useful, I'll have a go over the weekend at plugging the printer directly into an XP machine and sharing it on the network to the Vista machine.

  grabster 06:22 11 Apr 2007

You are correct in assuming my pc setup and my printer is set for sharing.
I will try your other suggestion later and post back my findings.

  grabster 20:28 13 Apr 2007

Well then,the printer works ok under vista when connected sraight to the lappy but any attempt to use the printer through the network just wont work.
I have the permissions set and as far as i can see things are set up ok.
Gotta say im stumped .
Hmmm.... any one have similar problems to mine ?

  toperic02 21:38 18 Oct 2007

Just wanted to say I have exactly the problem you outline. Not very helpful but thought I'd share your frustration

  mgmcc 22:54 18 Oct 2007

Have you installed the printer as a "Network" printer in Vista?

1) Connect the printer to the Vista "client" PC, as though it were to be used with that computer, and install it. This ensures that it has all the necessary software/drivers on board.

2) Reconnect it to the "host" PC and, in its Properties, set it as "shared". Make a note of both the host PC's "Computer Name" and the printer's "Share Name".

3) In the Vista "client" PC, launch the "Add a Printer" wizard and select the "Add a local printer" option. This automatically opens a new dialog box in which to select the Port.

4) Click the "Create a new port" radio button and leave the drop-down menu options on the default of "Local Port". Click Next.

5) A small box opens in which to enter the Port Name. Type in the path to the "shared" printer in the host PC using the format \\computername\sharename where computername and sharename are the details you noted in (2) above.

6) Select the Printer driver from the list provided, which should include the driver you originally installed, otherwise use the "Have Disk" button to install the correct Vista driver if it is not in the list. It is essential that a Vista-compatible driver for your printer is used. Click Next.

7) Give the printer a name and choose whether to set it as the default. Click Next.

8) Print a test page to verify functionality and then click Finish.

  4ndy 00:40 29 Oct 2007

i created the port and set up the printer on it just like the previous email said. it worked brilliantly thank you... but now a new problem... it stopped working after a day or so... or maybe just a computer reset.

I have desktop running XP and a printer (brother MFC 8440) connected to the USB port of that desktop which I am sharing over wireless network with my laptop running vista

I tried deleting the driver and tried reinstalling but the local port to my printer (address \\Andy\BrotherM) didn't show as an option and when I tried to recreate as per instruction here it tells me I can't because it all ready exists. So I renamed the printer on the network and reinstalled and it went fine and worked until i reset the computer.

When i looked at the ports tab of the printer properties I saw that the latest port I had created to the shared xp printer was not even in the list and no port was checked... thus the problems printing with the driver. However when I tried to add address as a port I was given an error message again saying that it was allready there.

It looks as if it is a problem with a disapearing port. Any one experience anything like this? It is driving me crazy!!!


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017