UAC: allowing users to run program

  ricvic 09:29 10 Sep 2007
Locked

My laptop has a hotkeys utility which is useful - I use it and want it. However when I log on as a user it gives a UAC prompt so that i have to run the utility as an administrator. This means that if others are using my laptop I would have to give them an admin password (big no no!). I want the hotkeys utility to run within a user account without prompt. I have so far tried running in compatibility mode, always run as administrator, editing permissions so that users and admin have the same rights. Nothing makes a difference. Any ideas?

  tullie 11:54 10 Sep 2007

I suppose you could allways turn UAC off?

  tullie 11:55 10 Sep 2007

I suppose you could allways turn UAC off?

  ricvic 12:49 10 Sep 2007

Given that the program requires admin credentials to run, would not turning UAC off simply block the program silently?

  Riojaa 12:56 10 Sep 2007

Try it and see.

I run with UAC stripped off.

Vista is simply XP with the holes covered over with designer gaffer tape and barbed wire.

  ricvic 19:10 10 Sep 2007

Sadly it does not work. It blocks the program and produces an error. I've uninstalled the hotkeys driver. It might have been useful, but it's too much trouble!

  Riojaa 21:48 10 Sep 2007

Try giving it rightful permission in the Firewall dept settings then.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017