trouble installing SP1

  kiz 11:39 13 Apr 2008
Locked

My laptop (Vista) is trying to install SP1.I have it set inform me when updates are ready to install, I gave it the goahead but although it has successfully downloaded the service pack, everytime it tries to install, it doesnt complete the job.The computer just stops on the installing updates page. I have tried using system restore, first to go back last step (first attempt at install) and then to yesterday's state, but each time it says SR is unsuccessful.
I dont know what to do now! should I try to delete the downloaded files and if so where do I find them? I am a bit worried that System restore didnt work at all.
I am not an advanced user.

  anskyber 11:45 13 Apr 2008

How long have you left it? The install can take about 40mins.

  kiz 11:53 13 Apr 2008

I have left it about 1 hour. I heard things ticking around inside but now it has stopped and I have just checked the update history and it says it has failed. I am worried because I did cancel the installation earlier after about 30mins today thinking it had stalled but it was probably still installing. It says cancelled in the update. What do the think is the best option now?

  anskyber 12:01 13 Apr 2008

Try another install.

  anskyber 12:03 13 Apr 2008

While the background to this advice click here is not the same as yours there are some checks on other updates required you may wish to check.

  mobileman1953 12:17 13 Apr 2008

make sure your firewall antivirus and defender are all turned off before install, dont forget to turn them back on after install

  kiz 12:21 13 Apr 2008

OK I will try and reinstall. I have had a look at the above help and microsoft websiet and feel a little more confident now. Will let yu know if successful.thanks

  kiz 12:59 13 Apr 2008

Success - it repaired itself, so alls well. Thanks everyone.

  aardvarx 16:24 13 Apr 2008

Big probs with SP1 - 40 min download, went to install and everything locked up. Three finger salute and re-started with task manager. Re-booted and tried to do a restore - somewhere in the download process, my restore history was wiped and I only have a post SP1 download restore point. Tried doing another download and all I get is zero Kb zero% progress and the little green worm wiggles away to eternity (and locks everything up if you try and cancel). Everything seems to be working but very slow.

Any help/advice gratefully received.

  michaleen 17:17 21 Apr 2008

I had the same problem,and microsft vista told me to un-install both virus and firewall from my computer,i did and it installed okay.don't forget to put them back on again.
michaleen

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?