Samsung S850 won't transfer via USB. Causes Error

  Hornman02 16:49 14 Feb 2008
Locked

I received a Samsung 8.1 Digital Camera over the Holidays. This camera has the capability to transfer from the camera to the computer via USB pictures that I've taken. When I first got the camera I noticed that it did not have drivers for Vista so I went to the site and downloaded drivers that were for Vista.

The problem is that the USB transfer does not work. I've tried contacting Samsung and they told me that I do not need drivers with Vista. Doesn't work.

That is bad enough but it is worse. In the Problem Reports and Solutions I continuously get this error over and over " Windows encountered a problem while installing device drivers for your Unknown Device.

I can see if a solution is available and delete it but it keeps coming back. Here is more information on the message.

Problem signature
Problem Event Name: PnPDriverInstallError
Architecture: x86
Win32 error: 00000057
Inf name: s385_drv.inf
Driver Package hash: a31ecce47f68c2595dc3ac9d3b745bb0fb26d3ec
DDInstall section name: Digimax.install
OS Version: 6.0.6000.2.0.0.256.1
Locale ID: 1033

Extra information about the problem
Bucket ID: 32030267

I have tried to find the problem in Event Viewer but don't know how to fix it so it doesn't keep showing up in Problem Reports and Solutions

If anybody can help me I would sure appreciate it. I don't know what else to do

  anskyber 16:56 14 Feb 2008

Get yourself a cheap card reader, they are just a few pounds and the transfer should go swimmingly.

The advantage of a card reader over connection of the camera to the PC is it uses the PC power whereas the camera battery is used in the way you are trying because it has to be turned on to work.

  anskyber 16:57 14 Feb 2008
  crosstrainer 16:58 14 Feb 2008

Anything you put on relating to the camera.

Samsung are correct, you need no software or drivers to copy your pictures in Vista.

When you have removed the software (thats the cause of your error messages) Just re-boot, plug in the camera (ensure it is set to DSC for the usb connection)

Vista will see it as a new removeable drive and allocate it a letter.

Double click the folder (probably DSC something) and you should be able to view, and copy your photo's.

  Hornman02 16:59 14 Feb 2008

From the information in the signature, I believe the problem is with the Samsung USB driver s385_drv.inf.

If I could find that driver, I believe I could eliminate it and thus stop the continuous loading of this driver and as a result the error listing in Problems and Solutions.

The problem is that I can't find the s385_drv.inf.

I can find the Windows/System 32/inf file but there is no mention of the s385_drv.inf.

I hope this additional information assists.

  crosstrainer 17:03 14 Feb 2008

Is there a samsung entry? If so remove it from there.

  Hornman02 17:04 14 Feb 2008

Am able to retrieve the pictures on the camera via a sd card. The problem I am having is that I can't seem to eliminate the constant driver error message in the Control Panel Problems and Solutions.

I know when I first installed the driver it said it was not compatible with Vista. I probably shouldn't have installed it but I did (I've done that with other programs and at least was able to uninstall them!!) Now all I get is continuous driver did not install error!

Thanks for the speedy response. It isn't affecting the overall use of the computer. It is just driving me crazy continuously getting these error messages.

  crosstrainer 17:04 14 Feb 2008

Use system restore to a point prior to installing the samsung software.

  Hornman02 17:18 14 Feb 2008

This first occured when I installed the driver for the camera that was given to me as Christmas Gift. Since it was December I am positive that it is not a good idea to go back that far with a system restore. I have checked for various restore points and I don't go back that far!!

Thanks for the ideas.

  crosstrainer 17:22 14 Feb 2008

Msconfig

start>run

type msconfig

press enter

select startup tab

look for entry relating to samsung and untick the box so it wont try to load at re-boot.

re-boot (if defender is on it will tell you it has blocked startup programmes..run the msconfig one once, it should not return)

  Hornman02 17:40 14 Feb 2008

I went to reg edit and did a scan for Samsung. It came up with over 30 instances of Samsung Digital Camera.

I thought it might make sense to clear the registry of all instances of the Samsung Digital Camera.

I backed up the registry and tried deleting. Some deleted but other instances would not delete. For some reason they are protected.

I have been trying to do something with this since December. If you look into this problem on Google, you will find instances at several help sites but no answer.

Samsung didn't like the idea of me going into the registry. I am comfortable with doing so and have worked in the registry on several occasions over the years.

I sure do appreciate all the people providing suggestions.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?