Prog won't initialize, asks to turn off read-only

  hannay 16:07 11 Apr 2008
Locked

Hi:

I do a lot of photo-cleanup etc for brochure-work etc in property-sales. I use PhotoDeluxe 3 because it can do all of what I want, and some things a lot better than "superior" progs. I have used PhotoDeluxe 2 and 3 right from Win 3.1 days through 98 and XP.

It has been fine on Vista Home Premium where I have edited/cleaned/manipulated hundreds of photos since the day I installed it on this new machine months ago now, but suddenly today the prog won't launch when I click its icon, and I get a message saying that it can't initialize because *the* file is locked, and to use the file manager to turn off the read-only option.

I have gone right through the programme folder and none of the files are locked. Folders aren't locked either, the check-boxes are just "blued" which means they are of an indeterminate state but are not locked ... I can clear or check that box readily anyway, though the folder will always be "indeterminate" straight away on re-inspecting.

I have uninstalled and reinstalled, have used system restore to go back to a number of different dates in the past when it was fine, including one WAY far ago, have tried installing PhotoDeluxe 2 the earlier version just to check that too but still the same message appears with both, wanting me to turn off the read only option on the file ...

I don't believe I have done anything significant to cause this that I can recall, have not changed settings, have now tried taking ownership, done the reasonable things but without any change. The only thing that could perhaps relate to anything is that a defrag was carried out overnight and right afterward was the first time the problem occurred. However, that then wouldn't affect operation when uninstalled and reinstalled ...

So ......

I am aware that there are some issues with Vista and unlocking of read-only files at times, but haven't found anything about a programme file suddenly being locked and stopping the application from initializing.

I am now [u]seriously[/u] in need of using the prog, and need to look for help from someone more expert ...

One thought is that the request to use the file manager to turn off the read-only option on the file may be referring to another file entirely, not one in the PhotoDeluxe programme folder ... and I wouldn't know where to go with that thought!!!

Can anyone suggest a next-step to get things working together again please - I doin't want to just leave it and have to use a different prog, and shouldn't need to anyway as PD3 has been fine right up to yesterday!

Any thoughts/guidance would be massively welcomed ...

Hannay

  anskyber 18:59 11 Apr 2008

Not sure if this will work with an executable file but you may want to try. click here

  Jim_F 21:39 11 Apr 2008

It may be worth trying an install in another directory (other than C:\Program Files) as Vista seems to be locking down any progtram access in this folder

  hannay 11:41 12 Apr 2008

anskyber - Thanks for that link, it is a good workthrough to double-check that taking possession was done correctly before, Thanks! I now have a workaround as described below, but am still looking for a fix if I can interpret what the workaround is trying to tell me, so if you can help with that feel free :)


Jim_F I have it in mind to give that a shot anyway ... as you see from below I now have a workaround that lets me use the prog at least, though it isn't a fix and I still want to get that taken care of. Thanks for the comment, and any further thoughts would be welcomed.

[U]For the benefit of anyone reading this later with same/similar problem[/U]

Turning UAC off makes the programme accessible.

It isn't a fix but does sidestep the occurrence of the programme not initialising.

I don't know right now what that points to and would still like to get that sorted so it will work with UAC on, as I don't have the problem that others seem to have with disliking UAC's so-called nagging ...

If anyone sees the relevance of this and cares to comment ot would be appreciated.

Hannay

  anskyber 12:05 12 Apr 2008

If turning off UAC works I wonder if this selective UAC control is a half way house?

click here

  hannay 09:01 14 Apr 2008

Yes it probably is ...

I have also discovered that with UAC turned back on again I can open the prog fine by right-clicking the icon or .exe and taking the "Run as Administrator" option that is offered ... seems a permissions adjustment is called for in this instance.

Hope this is useful to someone reading this later.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

What is ransomware and how do I protect my PC from Petya?

Microsoft Surface Studio – the artist's hands-on review

Original iPhone review

Comment mettre à jour Kodi ?