Problem With Windows Update

  Tracey73 14:24 13 Jan 2012

I've had a quick look to see if there were any threads concerning this particular problem but I couldn't find any, but apologies if it has already been covered. So to my problem...

For months now I've been trying to install one particular update - Windows 7 Service Pack 1 for x64-based Systems (KB976932) but it keeps failing, throwing up the error code 80073701. I've run the Windows Update troubleshooter but still no joy. If anybody can advise me on what to do or try I'd be very grateful. Thanks in advance!

System: Windows 7 Home Premium 64-bit

  KRONOS the First 14:41 13 Jan 2012

You could try downloading SP1 directly from here:Win7 SP1 and try installing it from your desktop as opposed to Windows update.

  difarn 14:54 13 Jan 2012

Try downloading this directly from the download centre here - see the attached article - the one you need is the last but one. This may take a little time.

It is also a good idea if you make sure all of your drivers are up to date.

  Tracey73 13:22 14 Jan 2012

Thank you for the quick replies!

I downloaded the update and installed from desktop as suggested, after over 2 hours I was told "Installation was not successful. The referenced assembly could not be found. Error: ERRORSXSASSEMBLY_MISSING (0x80073701". From here I clicked to try a system update readiness tool (which I'd not come across before), installed that and tried updating from Windows Update. This time it looked like it was going to work - got about two thirds of the way through but then threw up the error code B7. This morning (the previous took all last evening!) I thought I'd try istalling from desktop again since I now had the hotfix installed but was told I didn't have enough space as it needed 7 GB of space?!?! Decided to try updating from Windows update again which actually started doing something (before it just sat there with no progress on the bar showing). It told me it was installing the update, but failed again about half way through with the same old 80073701 error code back again.

Regards my drivers being up-to-date, what is the best way to check this? I gave the DriverGuide programme a go which ran a driver scan and told me there were about twenty with available updates (the other 50-odd don't need updating), but it all started going a bit above my head when errors were thrown up whilst trying to update these via there links. Some of these updates were for things like the webcam which I don't use anyway.

  Tracey73 13:24 14 Jan 2012

Sorry the above should read "ERRORSXSASSEMBLY" not "ERRORSXASSEMBLY"

  Tracey73 13:26 14 Jan 2012

^^^ Seems like it won't let me put an underscore after ERROR for some reason!

  difarn 17:18 14 Jan 2012

To check drivers are up to date:-

Start - type in Device Manager

A long shot - sometimes a language pack is downloaded accidentally that conflicts - if this is happened this should be uninstalled.

Start - Control Panel - Programmes - Programmes and Featues- once this has populated you will see on the left hand side "View installed updates" - check to see if there has been a language pack update and uninstall it.

In some cases SP1 has not loaded because other updates have not been installed. Go to Start - type Windows Update and check for updates (other than SP1) If there are any, download them.

To updated drivers:-

In Device Manager click on the following to open - when they are open right click on each component and you will be given the option to update driver software - click on this:-

Display Adapters Monitors Network Adapters Sound, video and game controllers

That should do for a start!

If you feel ready to have a go at installing SP1 again run the Readiness Tool - if it runs ok try reinstalling SP1 from Windows Live Update.

  Tracey73 10:10 16 Jan 2012

Thank you difarn, I really appreciate all your help!

I checked on language packs updates, but there were none. There were two drivers under network adapters that I updated, the rest were all up-to-date. There were no other Windows updates. Finally, I ran the Readiness tool which was fine so tried Windows Live Update but it stopped at half way on the progress bar again and told me the update had failed - with the same 80073701 error code.

  KRONOS the First 10:25 16 Jan 2012

Have you seen this? Win 7 SP1.

  difarn 11:55 16 Jan 2012

Sorry you are still having problems - if all else fails you could try doing an in place upgrade to replace missing or corrupted files as recommended by Windows under the post from Jason. This is in relation to the 0x80073701 ERRORSXSASSEMBLY_MISSING error

  Tracey73 18:20 16 Jan 2012

Thanks, Chronus. I've been trying a few of the tips on the 'How to increase you chances of installing Service Pack 1 successfully' via the link you gave and now have another problem! I tried renaming the Software Distribution folder, as suggested, to SoftwareDistributionOld and now when I run updates it just keeps searching and searching, never getting anywhere. I thought I'd try and revert back to the original folder name to rectify, but now I have two folders, one 'Softwear Distribution' and the other 'Softwear DistributionOld'. What should I do?!

Thanks difarn I've bookmarked that link.

10) Rename the 'Software Distribution folder':

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?