"Prefetch has stopped working"

  ened 07:26 03 Dec 2007
Locked

I have had this message twice over the weekend and, looking around, it appears to be related to a lack of memory.

But I have 4gig in this machine.

The only thing is that it is constantly using between 30-35% even when idle.

This prefetch problem does appear to be quite common but :

1)Does it matter?

2)Is there a way to resolve it?

  anskyber 08:36 03 Dec 2007

Prefetch is a form of a way of memorising the things you do on a regular basis. So for example if you always launch your browser, open the email program and other programs at start up then Vista stores some of the information in prefetch so that it can get to it quickly and speed up the boot process.

It uses a tiny amount of disc space to do it (2-4MB) so there is no resourse issue. Some people advise clearing out the "store" but that advice is not agreed by everyone, prefetch will after all just fill it up again.

Do you also use Readyboost using an external flashdrive, if you do with 4Gigs of RAM it is not really needed.

30-35% of idle RAM usage is not unusual, in fact quite normal. It will depend a lot on what you have running on your PC. Vista will always take advantage of available RAM and as you will know needs a fair bit of it for it's own use.

As to the problem, I regret I cannot help any further.

  ened 10:59 03 Dec 2007

If it stopped working I am presuming it will retrieve itself on a reboot.

Any idea how I can check it is working now?

  anskyber 11:05 03 Dec 2007

If it is the last couple of days have you considered a system restore?

  skidzy 16:39 03 Dec 2007

Vista's prefetch is also known as Superfetch,check your services to see if it has been disabled.

In your Start search type Services and enter or Services.msc and enter.

Scroll through the services till you find Superfetch and check this is set to Automatic.

  sinbads 19:13 03 Dec 2007

Also check registry superfetch is set to default

  Forum Editor 19:43 03 Dec 2007

Go to the start button, and type prefetch in the 'search' field.

There will only be one return, and it will be a prefetch folder.....click on it.

You'll be presented with a long list of filenames - delete all of them.

That should help things along.

  ened 06:27 04 Dec 2007

FE

I have followed your instructions and as well as the list of files there is a folder called 'Readyboot'.

I'm wondering if it is okay to delete this.

Incidentally this is MY machine (Built by ME) and I installed Vista, yet whenever I try to do something like this I am told I do not have permission - this is before the box about UAC.

Is there a way to give myself automatic permission?

  skidzy 17:01 04 Dec 2007

Try from an Elevated Command prompt;

Start / and type CMD and enter,now enter SERVICES.MSC and enter...you may still need permission,you should be able to just continue.

Alternatively activate the hidden super user account within Vista click here

  ened 17:41 04 Dec 2007

Thanks for the advice - I can always do the job I just find it irritating to have to keep confirming I want to do it twice.

I have looked at yourlink and will give it a try, but, when I de-activated uac before, other problems were created. If I remember correctly no cookies were active for frequently visited web pages and I had to type in Username/passwords everytime.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?