No USB after Sleep

  Graham. 23:39 23 Nov 2008
Locked

I have a USB keyboard and mouse. When I resume from Sleep the USB does not power up, so I have to shut down with the power button and start again.

Is this an update causing this? The PC is only 3 weeks old. Vista Home Premium.

  Sea Urchin 14:44 24 Nov 2008

Don't know whether this is relevant to your problem

click here

  Graham. 10:47 11 Feb 2009

Just been speaking to Zoostorm, the PC manufacturer. They advise that this is a known problem with Vista, which can affect any make of PC. Microsoft are yet to come up with a fix.

  peter99co 22:07 11 Feb 2009

Get in touch with Microsoft support. They do help if asked. Do not Phone, use emails

  Forum Editor 22:34 11 Feb 2009

been updated with Service pack 1 ?

  skidzy 09:12 12 Feb 2009

Ive had a similar problem in the past while trying to wake the system from sleep,this may help you click here

Alternatively;

Check your power settings in device manager;

Windows key + Pausebreak
Hardware
Device manager

Scroll down to the usb headings and expand the + sign.

Right click each usb root hub and select properties/power mangement...if this applies,untick Allow the computer to Turn off this device to save power and ok.
May take a reboot of the computer.

Also check your power options in Control Panel

  Graham. 10:03 12 Feb 2009

I've downloaded the suggested fix from Microsoft but it said it didn't apply to my PC.

Yes, Vista SP1.

All USB and Power options checked.

Given up - I've changed the brown button to Hibernate. Takes a little longer to start, but saves time in the long run.

  Graham. 10:08 08 Mar 2009

After much investigation by myself and Logitech, the keyboard manufacturer, it has been established that it is not a USB issue after all. The keyboard is starting up after Sleep or Hibernate, but the Macro function is not enabled.

The Logitech technician tried various cures, but we couldn't resolve it, so it remains a software mismatch with Vista.

A work-around was found, however. I right click on the Keyboard icon in the system tray, and select Exit. This stops the program. Then I go to Programs and start it again. I have pinned the program to the Start menu for ease of access.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Nokia 8 vs Galaxy S8

How artist Alex Yanes worked with his daughter on this bright 3D mural for Monument Valley 2

iMac 21.5-inch (2017) review

Comment regarder le lancement du Galaxy Note 8 en direct ?