No internet since upgrading to Windows 7

  User-6C1EF2B7-E8F9-4035-AD744DE23C5776A0 12:14 10 Feb 2010
Locked

Since upgrading to Windows 7 my desktop computer, which is connected directly to a Netgear DG834GT wireles router will not connect to the internet, although two laptops - recently upgraded to 7 - connect wirelessly no problem
The computer shows a LAN only.
Internet explorer appears to be no longer installed.
The internet troubleshooter can't find a problem

  JohnWilliams 13:33 10 Feb 2010

Have you installed wireless network drivers from your motherboards website?
Check device manager to see if there are any yellow exclamation marks next to any devices that need drivers.

  Technocrate 07:17 14 Apr 2010

I am having the exact same problem, with different hardware, but still the same problem. I've rolled back drivers, I've uninstalled updates, I've made it a static IP, diabled IPv6. I've read and done every suggestion I could find. I tried the NIC and the WiFi and they both have the same problem. It's really very strange. Did anyone else figure it out? I had the same problem on the Win7 64-bit so I thought that was it and now I installed the 32bit and am having the same issues. Its driving me crazy. I thought it had something to do with the DNS server maybe because I can download something and that usually goes uninterrupted. I feel like it has trouble making new connections. Avocado, do you have the same feeling?

For More Information and help related to windows 7 issues click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?