No Icons, cant uninstall - Help!!!

  Bob Bob™ 22:07 06 Jan 2009
Locked

Hello.
Some rather annoying problems here.

To summarise

1) Icons for Office 2007 wouldn’t display properly. If I opened a folder with office docs for example the white sheet of paper with the top right corner dog eared containing an application window inside it.
The shortcuts that appear in the start menu had no icons and wouldn’t work when clicked.

2) I installed COMODO firewall on recommendation from a user here over Zone alarm and it blocked my computer from the network and internet. I can’t uninstall the program. It’s not in the Programs list in control panel and it’s not in the programs list of Ccleaner. I had to disable a COMODO property in the Wireless networks settings to get my network/internet back.

3) I have since tried to uninstall Office to see if a reinstall will do anything to help the icons. I have no files to lose so I thought I may as well but when I press uninstall in the Programs section of Control panel it will return unsuccessful. When I press change it will gather files. The window would disappear and nothing would happen.

Office seems to still work but the icons will annoy me and the fact the installer won’t work properly is a concern.

I’m stumped

:(


Any ideas how to fix anything?

EDIT:
Looking at the Program remove page in Control Panel, there are a number of programs which are iconless. They, including Office, only have a dog eared white page as an icon.

Would the fact that I have used AusLogics Degfrag have anything to do with it?

Regards
Rob

  User-1229748 22:26 06 Jan 2009

have you tried a system restore to before comodo was installed?

  Bob Bob™ 22:30 06 Jan 2009

I dont have any restore points surprisingly. Its a fresh install of Vista (30 December) but there should have been some restore points made.....

  Bob Bob™ 22:37 06 Jan 2009

I tried to delete the COMODO folder and apparently I need permissions.

This is another thing that is absolutly frying my brain with Vista. I need permission to do almost anything on it.

When I change permissions, tick the boxes and press Apply the boxes I tick then are un ticked.

  User-1229748 22:48 06 Jan 2009

are you running as administrator?

  User-1229748 22:52 06 Jan 2009

it might be worth downloading,updating and running malwarebytes just in case you may have picked up a nastyclick here

  Bob Bob™ 22:55 06 Jan 2009

I believe I am, when I go to user accounts it says I am.

I do have the option to run programs as an administrator. Odd that it doesnt do it anyway.

Thanks for the link.

Ill give the comp a scan and while Im at it Ill get Spybot S&D and AVG going.

  User-1229748 02:32 07 Jan 2009

sas is another good antispyware,this and malwarebytes are well thought of by people on these forums and are free to use as manual scannersclick here

  User-1229748 02:39 07 Jan 2009

you could also try to reinstall comodo and try revo uninstallerclick here

  brundle 09:45 07 Jan 2009

You're not actually administrator in Vista as such, unless you take some steps to enable access to the true "administrator" account. Re-install Comodo (if possible) and it ought to add its un-install information to the Programs and Features list for you to remove it properly. Read this to remove Office 2007 (click here) and re-install it afresh.

  brundle 09:48 07 Jan 2009

CCleaner uses the same program list as Programs & Features, and only uses the program's own uninstaller for removal (as does Revo initially, but it does an actual search for leftover files and registry entries).

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017