New wireless card not working

  mousee 20:19 06 Apr 2011

I've just built a new machine running Windows 7 pro SP1 64bit, the mother board is an ASrock N68-S with an Athlon 64X2 dual core 5200+ 2.71 Ghz with 2 gig.
I seem to be having problems with the TP-Link TL-WN350GD, I've installed the software but the the troubleshooter is showing "the local area connection" is not working properley and there may be a problem with the driver for the wireless network connection adapter, both items show detected, but the icon on the bottom of the screen has a red cross through it.
Can anyone shed any light on the problem please to help me resolve this?



  a member 20:31 06 Apr 2011

did you check ,the correct driver is installed , via device manager .
the only windows 7 compatible driver I can find for your adapter is click here
often windows will install the driver it thinks is best and ignore the correct driver especially if its unsigned . go into device manager find your device and select update driver ,dont use the automatically find best driver option .select let me choose , hopefully your correct driver will be thee as an option .if not ,extract the driver to a folder on your desktop and go through the update driver settings again this time choose browse ,navigate to the folder and to the driver file and install ,if its unsigned or unrecognised ,you may get a warning but choose yes to install it ,restart and you should be up and running .

  mousee 21:09 06 Apr 2011

Thanks for the reply, I've looked on that site but as I'm using the laptop for the internet, it will only load the same driver as is installed on the laptop, I've had a good look on the disc that came with the adapter and the only one I can load is, TP-LINK 11b/g Wireless adapter #2. I still have the same icon on the task bar, which is the signal strength indicator with the red cross through it, when I hover over the icon it shows there are "no connections available", this has me confused, I may call it a night and try again tomorrow.
I've tried updating the driver through the device manager like you suggested and its loaded Atheros AR5007G now???????



  ams4127 23:15 06 Apr 2011

Just a thought. Have you disabled the onboard Lan chipset which is probably using the Atheros driver?

There was a conflict on mine when installing a TP Link N wireless adaptor.

  mousee 00:27 07 Apr 2011

I haven't disabled the chipset, but there is no Atheros drivers on the machine, I'm going to take the wireless router up to the attic room tomorrow and try to hook it up using the ethernet cable and see if I can update the drivers that way.

  ams4127 22:47 07 Apr 2011

"I've tried updating the driver through the device manager like you suggested and its loaded Atheros AR5007G now???????"

"there is no Atheros drivers on the machine,"

Sorry, I'm lost...

  ams4127 23:04 07 Apr 2011

Right let's start again!!

A couple of months ago I installed a TP-Link TL-WN951N wireless card in my desktop machine. Now, this may differ from your setup but all I can do is repeat what I did. Win7 64bit.

When I installed the card and rebooted I was met with the "Found new hardware wizard". That must be cancelled and then insert the "TP-Link Resource CD" and follow the Setup wizard. You should then get a TP-Link icon on the bottom right of your desktop and connect to your router from there.

If this is different to your setup, then I can only apologise for wasting your time.

  mousee 16:32 09 Apr 2011

Thanks all, got it sorted eventually, had to do a full install though, not a clue what had happened, bt never mind, were up and running again.



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Intel Coffee Lake release date and specifications

12 Amazing British Craft Beer Label Designs

watchOS 4 review

Les meilleurs navigateurs internet 2017