Network Adapter and Vista

  heimdallr 00:30 10 Jul 2007
Locked

Each time I want to connect to the internet after booting up my PC,I have to reset the network adapter using the diagnose and repair function. It's a Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller on a Gigabyte motherboard. Any ideas as to why it does this, and how to cure it?

Cheers

  mgmcc 07:36 10 Jul 2007

What is the problem with the adapter on booting - a failure to get an IP address from the router?

If so, go to "Start > Run", type SERVICES.MSC and click OK. In the Services window scroll down to the DHCP Client entry, double click it to open its Properties and check that it is "Started" and that its Startup Type is set to "Automatic".

If that's all OK, try giving the network adapter a fixed IP address in the same Subnet (IP address range) as the router. Post back if you need instructions for doing that.

  heimdallr 07:51 10 Jul 2007

Checked the DHCP client, settings the same as you described, if you let me know how to give the adapter afixed IP address I'll give that a go. What I don't understand is why it doesn't just connect the next time I boot after running diagnose and repair? Probably going to be a 'doh moment when its solved!!!!

  mgmcc 08:43 10 Jul 2007

Go to "Control Panel > Network & Sharing Center" then click the link on the left "Manage Network Connections". Right click the Local Area Connection and select Properties.

Untick the box for "Internet Protocol Version 6 (TCP/IPv6)". Leave version "4" ticked!

Highlight the entry for "Internet Protocol Version 4 (TCP/IPv4)" and click the Properties button. Click "Use the following IP address" and enter these settings:

IP address - 192.168.x.5 [where "x" matches the third part ("octet") of the router's IP address.]

Subnet Mask - 255.255.255.0

Default Gateway - 192.168.x.1 [the router's IP address]

DNS Server - 192.168.x.1 [the router's IP address]

This assumes that your particular router uses a 192.168.x.1 address, but it could use something like 192.168.x.254 or even a 10.0.0.x address. Ask again if you get stuck.

  aussietaff 06:09 03 Aug 2007

Hello mgmcc
I have exactly the same problem as heimdallr but I do not quite understand what you mean by :192.168.x.5 [where "x" matches the third part ("octet") of the router's IP address.]

My Modem/Router is a Billion 7402 and the routers IP address is 192.168.1.254. Would you please be able to tell me how and what I replace the "x" with. could you actually tell me what numbers I need to enter. I understand everything else OK. Your help would be much appreciated.

  dale303 21:29 23 Feb 2008

Did anyone manage to sort this out once and for all? I have the same network card and the same problem. Aside from the suggestions in this post, assigning a static IP address for the PC makes no difference.

I've also tried various drivers, old and new from both MS and Abit (my m-board manfacturer) and none of them make any difference.

PC only has proble from boot. Hibernation/sleep are always fine.

  heimdallr 14:06 25 Feb 2008

I've not managed to find a solution to this, in the end I just learnt to accept it as one of Vistas little foibles, que sera!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

The secrets of creating gory VFX

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache