MSI GTX 970 GAMING 4G No signal, and fans not spinning, but ''MSI'' sign lights up

  zewolfie 22:44 26 Nov 2014
Locked
Answered

So I've recently tried to upgrade from AMD (I uninstalled the drivers) to geforce gtx 970, but as the title says, it's not working. Fans aren't spinning, I get ''no signal'' but the ''MSI'' text lights up on the card. I tried to install drivers etc. By connecting my pc screen to my motherboard, but I can't install nvidia, because it says it can't find the graphics card. When I go to see the drivers, all I can see is ''VGA'', and when I try to install it, it installs intel 4000 drivers for some reason... I've put the card in the PCI-E slot (which I only have one of, other is PCI, and I've made sure it really fits and stays there etc.).

I'll put my specs here, in case:

Processor: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz

Video Card: AMD Radeon R7 200 Series (current)

Memory: 8.1 GB

Operating System: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit

Motherboard: MS-7798

PSU: Corsair CX 600W

  daxian 10:51 28 Nov 2014
Answer

hi .... have you plugged in the extra power cord ....the 970 needs extra power to work ! should be a power lead with pci-e coming from your power supply, plug it into the graphics card and it will work !! .

  zewolfie 04:44 29 Nov 2014

Yes, I have. As I wrote, I suspect it is what makes the ''MSI'' text light up :/

  daxian 10:53 29 Nov 2014

hi again .... "yes i have ,as i wrote " where ????? your motherboard has 2 pci-e slots and 2 pci slots (ms 7798) not one .... here is a vid of how to install a graphics card ,its not your specific card but the process is the same ,might give you an idea of the process. click here it helps...

hope

  zewolfie 20:15 29 Nov 2014

Actually, you fixed it for me, when you said ''have you plugged in the extra power cord'', I had only plugged in the extra power cord....................... Thanks man! :DDD

  JohnSchulting 04:11 27 Jan 2015

So do i have to hook up both the 6+2 power connector AND the other one beside it? i am installing the same card and have the same problem

  JohnSchulting 04:15 27 Jan 2015

So do i have to hook up both the 6+2 power connector AND the other one beside it? i am installing the same card and have the same problem

  zewolfie 08:52 27 Jan 2015

Well, I connected one cable from my PSU as well as the extra cable that came with the 970.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?