Mouse Problems

  Pine Man 14:35 25 Mar 2007

I am not sure if this is related to vista BUT!

I have a Logitech Pilot Optical Mouse, which came with my new PC loaded with Vista Home Premium.

The mouse appears to work perfectly until I connect to the internet and then it is as if the right button goes to sleep! If I want to cut and paste I have to hold the right button down for several seconds sometimes before the menu comes up.

The drivers for the mouse were originally the Microsoft generic ones but I have changed them for Logitech ones but no difference.

  Kate B 14:41 25 Mar 2007

Which browser are you using? Does that happen in, say, both Firefox and IE7?

And is the mouse wireless? If so, try it with a wired mouse.

  Pine Man 14:49 25 Mar 2007

Thanks for your response.

I am using IE7 and I have a 'wired' mouse.

The cursor works fine and so does the left button and wheel - just the right button falls asleep after not being used for a while.

  Pine Man 14:56 25 Mar 2007

I just found my old Logitech USB Optical Wired Mouse and tried that with exactly the same result.


  Pine Man 15:02 25 Mar 2007

I hadn't noticed but the left button also seems to fall asleep as well!

  Pine Man 15:37 25 Mar 2007

Just found a Microsoft Intellimouse with wire and a ball!

Just the same - must be Vista or some secret setting somewhere?

  Kate B 15:39 25 Mar 2007

That really is odd. Try Firefox and see if it happens using that browser.

  Pine Man 15:51 25 Mar 2007

Thanks for getting back.

I haven't got Firefox but I did find some shiny new Microsoft drivers for the intellimouse designed specifically for vista - didn't make any difference at all!!

I thought this one was a mouse hardware problem
as I lost the right button on my Razer.
This has happened three times and on each occasion it has been when the mouse was running
on the Vista stock driver. As soon as I installed the Razer drivers it went away, stock driver bug?
Who knows?

  Pine Man 16:22 25 Mar 2007

I have tried microsoft generic drivers, logitech drivers and a specific microsoft driver - all the same!

  madmartyr 21:40 25 Mar 2007

Hi, I have had the same problems, Wireless usb and keyboards just stop working for no reason. So far I have had problems with Belkin, Advent and creative products. It seems Vista( X64 ULTIMATE - I use )has problems picking up this type of product. Even tried using a usb mouse on a PS2 converter connector and its still stops working after a while.

I even bought Microsoft Wireless 2000 keyboard and mouse set and Vista had problems assigning the drivers(Downloaded from Microsoft web sight).

However if I use a wired PS2 mouse and keyboard theres no problems.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache