Mouse disappears or is frozen using Windows 8.1

  puzzled890 15:50 20 Oct 2013
Locked

Mouse (Logitech M185) has either disappeared from the screen or is frozen at some point. Although it worked OK at first after recently updating to 8.1 this problem has begun. Tried changing battery but made no difference.

  christina.john 11:03 04 Nov 2013

First, I would suggest you to follow these steps and run the Hardware and devices troubleshooter:

a. Press Windows key + W to search Settings.

b. Type “Troubleshoot” without quotes and click on Troubleshooting in the results displayed on the left side of the screen.

c. In the new window, click Hardware and Sound.

d. In the list of options, click on Hardware and Devices.

e. Click Next and follow the on-screen instructions.

  Mark_Hayward 14:50 04 Nov 2013

The same thing has happened in Acer V5 Touchscreen which now has no Mouse Pointer, even restart or restore doesnt fix it. Touchpad doesnt work either. Also happens fairly regularly in my Samsung, but the pointer returns after a few seconds. Both devices running W 8.1 and never had it happen in W 8, just plenty of other issues instead.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone