Kodak 5300 printer not working with Windows 8.1

  Dragonfly2 11:56 11 Feb 2014
Locked

We recently bought a new computer with Windows 8, and managed to print successfully on our Kodak 5300.

After a few days we upgraded to Windows 8.1, and are now no longer able to print, scan, or even access the printer from the computer. It was OK with 8, but not with 8.1.

We can't see any mention on Kodak's website of a driver for Windows 8.1. Best we can see is a driver for Windows 7.

Can anyone advise how we can sort this out?

  Woolwell 12:33 11 Feb 2014

Install the latest driver from Kodak support

  Dragonfly2 13:29 11 Feb 2014

Hi Woolwell,

Many thanks - will give it a go. But we've been onto the Kodak website and looked for drivers for our specific printer, and Windows 8 wasn't mentioned there.

Perhaps we weren't looking at the right thing - will find out soon!

  Woolwell 16:43 11 Feb 2014

The link that I provided should take you directly to the download for the W8.1 driver for your printer. I notice it doesn't state your printer but I got to it by selecting your printer.

  Dragonfly2 20:09 11 Feb 2014

Hi,

We've tried the link you suggested - and it didn't work.

We downloaded the installation program, and then executed it. We had three options, and chose the one to upgrade. The message told us that everything is completely up to date. But we still couldn't print.

So we then uninstalled the printer and using the installation program, installed it from scratch. This seemed to go OK.

It asked to be connected via USB cable. Even though the printer is physically connected to the computer and switched on, the message came up that the printer is not detected.

I don't know if this is relevant, but the printer cable linking the two is about 7 metres long, as they're on different desks in our study. This hasn't been a problem up to now. All problems started with upgrading from Windows 8 to 8.1.

Any advice would be appreciated please!

  Woolwell 21:38 11 Feb 2014

Uninstall the printer completely first then install the drivers again. I suspect that you have a corrupted driver.

  Dragonfly2 13:01 12 Feb 2014

Problem now sorted out, many thanks for the help.

We'd obviously downloaded the correct driver as suggested, but then had a second problem.

We had the printer connected via a USB hub. When we put the cable directly into the computer, rather than via the hub, the printer worked! We don't understand why it worked through hub before though, but for now will leave it as it is.

So hopefully now all is well.

  Woolwell 16:16 12 Feb 2014

Glad it is sorted. Should have asked if you had tried a different USB port.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?