How can an XP laptop print via a Vista PC?

  knapps 10:53 05 Oct 2007

My desktop is linked via USB to a Canon Laser Printer and to a Canon Inkjet.
My laptop prints via the desktop.
Both ran Windows XP.
I have upgraded the Desktop which now runs Vista premium.
The Canon Laser has no available driver so has been disconnected.
I cannot get the laptop to print. I'm sure all my sharing is OK (unless there is a less obvious thing I could have missed).
Any ideas gratefully received.

  crosstrainer 11:24 05 Oct 2007

A vista compatible driver, you are stuck.....Even if your file and print sharing settings are correct (XP default=MSHOME Vista default=WORKGROUP) these must be the same, but if all is well here, then the driver issue is your problem.

On first attempt to connect to the printer, Windows attempts to retrieve the driver from the other computer, if it's not Vista compatible, I'm afraid it might be new printer time (or use a usb drive to carry the files across for print purposes)

  aquatarkus 14:16 05 Oct 2007

make sure the printer is set as shared on the vista machine and that both pc's have the same workgroup name then on the xp machine go to add printer and select the option for printer connected to another pc, windows xp will search for the printer and should if its shared and both pcs have same network group name find it it will then ask you tofor the driver either download the driver from the canon site for the xp machine or if your very lucky it will already have a driver and will install it on the xp machine. the only annoying feature will be that every time you want to print Vista will ask you for a user name and password to access the vista pc unless you create a user account on the Vista PC for that person.
might be easier to se if your router either wireless or wired has a print server port or maybe add a print server, netgear, Buffalo etc do them from about £30 at your local computer fair.

  Ashrich 14:27 07 Oct 2007

On the Vista machine , go to start/settings/printers , select your printer and right click on it , select " properties " and ckick on the " sharing " tab , tick the boxes for sharing the printer , Ok your way back to the desktop .


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans échec ?