Help Vista system restore

  mcut 08:55 09 Dec 2008

i had noticed i could not run a system health check report and saw on other forums that SP1 could be causing problem. i uninstalled SP1 and it still did not work.

I tried earlier system restores but they ran for absolutely ages and then told me there was an error and no system files were changed.

i then tried a system restore in safe mode in case antivirus (kaspersky internet suite 2009) might be causing system restore not to work.

the laptop froze for 30 mins at the restore intialising screen and then froze for 8 hours at the system restore is changing registry screen. i had to physically remove the battery and mains to get vista to eventually boot up and now i have no service pack 1. windows update also suddenly decided that it could not update itself so i cannot update online to SP1 either

any suggestions friends

  rdave13 09:08 09 Dec 2008

As you've no SP1 then try running the system file checker; click here

  mcut 11:59 09 Dec 2008

i have run the system file checker. i get message that windows resource protection has found corrupt files but was unable to fix some of them.

it then tells me that details are in the cbs log and says windir\logs\cbs\cbs log. when i type this in the command prompt i get no such path.

my command prompt starts with c:\windows\system32\ and i cannot get a prompt to start with c:\windir\logs etc if that is what i need to proceed with this problem.

the vista install was an upgrade install, clean install over XP, done 2 years ago and this is the first problem i have ever had with it.

  mooly 16:53 09 Dec 2008

There was something a while back that before SP1 a file check (SFC/ SCANNOW ) did in fact report uncorrectable errors when in fact there were none.
That's something I can confirm. It used to work, then an update "broke" it. MS were aware of the issue and it subsequently got fixed, I think with SP1.

  mcut 16:57 09 Dec 2008

i have now managed to reinstall SP1 from Windows Update and performing a SFC scannow results in no errors.

i could not set a restore point and worked out this was because event Log and Task scheduler were turned off. when set to default boot up i can now set restore point.

do you think the system restore did not work in the first place due to these services not being on

  Pine Man 16:58 09 Dec 2008

Ever since I got Vista nearly two years ago I have never had System Restore working properly. I get the same response about corrupt files and despite trying everything suggested on this forum and many, many others I have not been able to fix it.

My solution was to disable it and install Acronis True Image.

The idea of System Restore is good but if you can't trust it why use it at all? Acronis has never let me down.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?