Generic USB hub not starting

  aphrodite42 17:04 08 Oct 2014
Locked

I use a Belkin USB hub on my W7 PC to which is permanently connected printer, scanner and card reader and occasional use of USB sticks to store files. Over the past few days the hub has sometimes failed to start when the PC powers up and in Device Manager is marked with a yellow exclamation mark. Sometimes a restart cures it straight away, sometimes not. I have checked all connections are secure and the power light on the hub is lit. I have scanned with MBAM in case it was caused by a 'nasty' but the report came back clear. Help!

  Fruit Bat /\0/\ 17:51 08 Oct 2014

remove scanner priter etc. from hub

Uninstall it in device manager

and reboot.

plug in scanner printer etc. let windows reinstall the drivers.

  aphrodite42 16:05 23 Oct 2014

Sorry for delay in responding - I have been ill.

Followed your advice to uninstall hub and this completely crashed PC, blue screen of death and all sorts of frightening messages. Eventually I managed to restart in Safe Mode and rolled back to a restore point and after 2 more restarts everything is working again except the hub. Just to clarify what I did. Device Manager, opened the generic usb hub entry, clicked on the Driver tab, clicked uninstall. When the hub is not working in Device Manager the narrative is: 'The device cannot start (Code 10)' although strangely this afternoon it has decided to work.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?