Flash Player not recognised on BBC iPlayer

  griffon56 17:38 20 Jan 2016
Locked

Hi All,

Running Win 10 on Packard Bell iMedia D2525. When trying to play BBC iPlayer prog a pop up box requests that Flash Player is loaded. Well, Flash Player already IS loaded and installed, as recorded by a couple of lists including the Tools list of CCleaner, so how do I get the system to recognise this, please?

  Govan1x 18:35 20 Jan 2016

Run Windows update and see if there is an update for flash player.There was one about 1 week ago i believe.

That is of course if you are running I/E11. If a different browser you would need to download the latest version for that.

  wee eddie 21:21 20 Jan 2016

It may be something of a bore but have you tried reloading Flash Player.

I had a couple of months of this and one day it sorted itself.

We had a long chat here and I tried several solutions, unsuccessfully.

  griffon56 12:25 21 Jan 2016

Thanks Govan 1x and Wee Eddie, I've re-installed Flash Player repeatedly lately thinking along the same lines. No effect. It worked fine with Win 7, it doesn't with Win 10. However, whenever Flash Player is installed it doesn't seem to finish logically, it just displays page 3 of the install process with an invitation to view a photo which it thinks you might like with an invitation to buy/adopt the software which produced it. Is this OK?

  Govan1x 14:25 21 Jan 2016

griffon56

It usually installs then shows the 3rd page i usually delete it before the 3rd page shows.

What browser are you using when the flash player does not work.

  griffon56 15:03 05 Feb 2016

Firefox Govan1x, and Flash shows as installed in CCleaner's Tools programs list so thgere's no reason why it won't play. It did on Win 7. Please don't concern yourselves any longer I'll just get out the lump hammer.

  Govan1x 17:20 05 Feb 2016

Have you checked your add ons on Firefox if anything wrong with firefox it will disable it. If it needs updating update it from firefox add ons.

Also have you got Firefox up to date. It is version 44.0 now.

  rdave13 19:14 05 Feb 2016

Make sure no browsers are running then uninstall Flash. Restart the PC (not shutdown). Run Ccleaner and its reg cleaner. Try this link in Edge first. Try again in Firefox and hopefully you will be asked to download the latest Flash plug-in.

  wee eddie 20:01 05 Feb 2016

I have just experienced this. I think that it is Malwear, posing as Flash, but I have only had W10 for a couple of days and have been too busy with coming to terms with a new OS to follow it up

  rdave13 20:21 05 Feb 2016

wee eddie try the link I posted in Edge; see if it works. As a new OS, if a clean install, you shouldn't have bugs.

  wee eddie 21:59 05 Feb 2016

Rdave13 : it's nothing to do with the Edge. It's coming from the iiPlayer site. I've checked with Flash and I have the latest version available for Flash which is why I assume that it may be malware or an error on their part

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?