External hard drive inaccessible

  bigrad 12:46 08 Jan 2014

I am running W8.1

I have been using a seagate external 1TB hard drive for my file history back ups for some time with no probs. Today I find that although the system recognises the drive and gives it a letter and shows no problem in device manager it will not allow access and reports "The request failed due to a fatal device error"

I have run the usual troubleshooter options with no errors reported and when I connect the drive to another PC running vista it works just fine.

The drivers are up to date and I have not changed the system in any way or downloaded anything.

Any ideas on how to sort this out and access the drive in W8 would be welcome


  rdave13 19:36 10 Jan 2014

Have you sorted it yet? If not, it seems like an old problem with Vista and 7. It works when connected to XP then change the letter to one of the lowest in the alphabet while in XP. Connecting back to Vista or 7 then it would be 'seen' again. Try changing the letter in Vista then connect again to Win 8.

  bigrad 06:17 26 Feb 2014

It was rude of me not to answer - sorry I got distracted. No I never did sort it. I tried all the stuff with letters etc but no joy. I've tried connecting again to other machines but I cant access it at all now no matter which OS I use. Right now its just an expensive paperweight.

  BRYNIT 08:29 26 Feb 2014

You could try Easeus Partition Master free CLICK HERE or try removing it from the case and connect it direct to the PC as an internal drive.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires