Error messages when installing Windows 7 SP1

  akpak 12:21 28 Feb 2011

I've just used Windows Update to install SP1 on two more or less identical computers with Windows 7 Home Premium 64-bit. On one of the computers only the following error and warning are showing in the event viewer, from around the time the actual installation started (ie immediately after the download completed):

Error - Source VSS, Event ID 12305 Task Category None:

Volume Shadow Copy Service error: Volume/disk not connected or not found. Error context: DeviceIoControl(\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy18 - 000000000000012C,0x00560034,00000000002F0FE0,0,00000000002EFFD0,4096,[0]).

Processing PostFinalCommitSnapshots

Execution Context: System Provider


Warning - Source Ntfs Event ID 57 Task Category (2)

The system failed to flush data to the transaction log. Corruption may occur.

(end of messages)

Both messages showed exactly the same time. System restore shows that a restore point was created at the same time, which suggests that it did manage to create a restore point despite the error.

I tried restarting the computer, and it didn't try to run chkdsk (which I would expect it to do if there were any disk errors, and which has been mentioned on other forums). Disk management shows all disks and partitions to be healthy (before and after the restart).

Please can anyone tell me what's going on and if I need to worry about it. Many thanks.

  omegaalpha 13:40 28 Feb 2011

@ akpak - that is certainly strange. Have a read at this link; it's a support article from Microsoft and there are two things to consider before installing SP1 which are exlpained in the article; click here

Another thing to try is downloading the SP1 from MS download centre to a USB key, uninstalling the Service Pack and then reinstalling the SP1 from the USB Key - it could be that the download via Widows Update may have become corrupted.

Apart from that - I am not completely sure what to do.

  akpak 14:36 28 Feb 2011

Thanks for the response. I checked everything in the MS article before installing, and all seemed OK. Also, SP1 appears to have installed correctly - the installed updates window shows it as successfully installed, and system properties says I now have SP1. So I'm a bit uninclined at this stage to remove it and start again. It took a good 40 minutes in all, and I haven't time to do it again today.

  ams4127 19:47 28 Feb 2011

This is a problem I have encountered before when installing updates/patches.

In all instances rebooting the system seems to allow Win7 to "sort itself out" and, after a bit of whirring HDD noise, all is well.

Personally, I wouldn't worry too much.

  akpak 17:23 01 Mar 2011

Thanks for your input. A reboot was part of installing SP1, and there was so much configuration going on that I'm not sure if there was any additional HDD whirring or not!

I do still feel a bit concerned that some data has got corrupted somewhere, and I'm wondering why the VSS thing couldn't find the volume/disk.

I'm guessing that Windows was doing some kind of backup at this point, but it's not clear if it tried again and succeeded. But I'd probably feel a bit happier if I knew what had been happening and why it went wrong.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017