Epson D88 Problem

  Woolwell 10:17 25 Jan 2012

Have a new computer with Win 7 Pro 64 bit and everything is fine apart from the Epson D88. The drivers for it are part of Windows (nothing to download). I installed it and it worked fine initially but for the past 24 hours it refuses to work. I can access the ink levels but cannot print a test page and I get "Operation could not be completed (error 0x000000c1)". I have changed USB port, changed cable, changed powered hub, connected directly to the PC, uninstalled the printer, re-installed and still the same error message comes up. I have set it as the default printer too and that doesn't fix it.

A google search throws up Vista installation problems (installing a printer) but it appears to install without a snag and the properties are ok. Many of the answers point to dubious registry cleaners.

Another real oddity is that it will print the nozzle check but not a document.

Any suggestions?

  sharpamat 10:46 25 Jan 2012

This model whilst seen by windows 7 has no drivers available from Epson for as it is not supported.

You can try installing from CD useing compability mode, or download the Vista drivers from epson use the compability mode to install the driver

  Woolwell 12:04 25 Jan 2012

It ran ok at first on the Windows drivers and is listed under the Windows printer when you add a printer. Epson state that the driver is included in Windows. However I'll try the Vista drivers. They worked fine for my scanner which is supposedly not compatible with W7.

  difarn 09:04 27 Jan 2012

It does sound as if the driver does need an update. Have you tried doing this through device manager? According to this Epson site there are drivers available for D88 but am not absolutely sure that this is your machine. There are quite a few blogs that say that this printer is fully compatible with Windows 7 but you will need an updated driver. Should there not be a specific Windows 7 driver then as Woolwell says the Vista driver should be ok.

  Woolwell 13:07 27 Jan 2012

Vista driver did not work. The D88 is supposed to have the driver built into W7. It did initially work but now fails every time although I can check ink levels and print nozzle checks. I shall now abandon this and connect it to my Vista laptop. It isn't a show stopper as the D88 was my backup printer and was in the process of being retired. It's retirement has now been brought forward.

  difarn 13:33 27 Jan 2012

Sometimes we have to admit that something may not work but the error message you are getting is in relation to a driver problem and Epson insist that your printer is Windows 7 compatible.

As a final try, possibly, do you feel like going through it and manually installing a driver from the list populated? If so you need to uninstall the printer completely, again. Disconnect the printer and then re-connect

o manually install a printer driver

Open Devices and Printers by clicking the Start button  and then, on the Start menu, clicking Devices and Printers.

Right-click the printer you want to update, and then click Printer properties.

Click the Advanced tab.

Click New Driver, and then follow the instructions in the Add Printer Driver wizard.
  Woolwell 13:38 27 Jan 2012

difarn - I've already done all of that. I think that somehow the driver has become corrupted. A fresh install/repair of windows could cure it but I'm not going to bother with going down that route and possibly cause greater disruption elsewhere.

  difarn 14:03 27 Jan 2012

I don't blame you for not wanting to do a re-install/repair. It does sound like a corrupted registry entry. If you do not already know of CC Cleaner it is well recommended for finding such errors and repairing them. I don't advocate using registry cleaners regularly but only when you suspect a fault. If you did want to do it this is the download. I would recommend doing the light scan and saying yes to backing up.

If you don't know this tool already it is very useful for clearing out all elements of programmes left behind by an uninstall and for a general tidy up without a registry scan.

  Woolwell 14:45 27 Jan 2012

I ran CCleaner before my original post.

  Woolwell 14:46 27 Jan 2012

ps Should have mentioned that I did that.

  difarn 15:27 27 Jan 2012

Thanks for letting me know - some things are not meant to be.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Musique en streaming : Spotify vs Deezer