Caps Lock delay in Windows 7

  Jim S 15:53 22 Feb 2010
Locked

When I hit Caps Lock in Windows 7 an alert (picture of a padlock in grey) icon appears indicating I have turned it on or off. While the alert is showing no input from the keyboard is accepted. This is frustrating because I usually hit Caps Lock and type immediately, and then find about 6 letters have not been accepted. The speed of the system (laptop) is otherwise OK. Is there a way to reduce the time the alert shows, or turn it off altogether?

  mrwoowoo 00:11 23 Feb 2010

I don't think that's a Windows 7 thing.
Have you installed any keyboard software to make it do all kinds of fancy things such as
function keys to quick launch certain things?
If you have used an installation disc that came with the keyboard then you could always uninstall it.

--

  Jim S 21:39 23 Feb 2010

No, I haven't added anything. Machine is as bought new, wioth various pieces of software like OpenOffice added, but nothing keyboard specific.

  peugeot man 09:32 24 Feb 2010

I have Win7 on a netbook and a PC, caps lock is instant no delay whatsoever

  mrwoowoo 16:10 24 Feb 2010

Is it a laptop or PC tower?
Could try going into control panel > keyboard and seeing if there's any settings there you can change.
If not, then in the same location click on hardware tab > properties and driver. Then update the drive incase it's corrupted.
If it's already up to date then uninstall the driver and then reboot your PC. It should ask you to restart the PC before it takes effect.

  Jim S 17:00 24 Feb 2010

It's a laptop. I've tried changing some of the setting such as a sound alert that operates when you press Caps Lock, but that had no effect, so perhaps there is indeed a corruption in the keyboard driver. I'll give it a try.

  mrwoowoo 18:36 24 Feb 2010

If it's a laptop then perhaps you could contact the manufacturers for some tech support.
Maybe it's setup the same in all their laptops.

  a member 19:46 24 Feb 2010

control panal /ease of access/make the keyboard easier to use /look in there ,sounds like the problem turn off toggle keys /untick.

  Jim S 19:46 24 Feb 2010

I went to Ease of Access and checked the toggle keys box to make Caps Lock etc. make a sound when pressed. This solved the delay problem. The grey padlock still appears but there is no delay in input from keyboard. Thanks to all for suggestions

  a member 19:55 24 Feb 2010

turn off sticky keys ,or change the settings ,there are settings to play a sound when a seetting is used and to show a warning when a seetting is pressed .try these settings .

  a member 19:59 24 Feb 2010

in fact there are a whole host of potential causes/settings in the ease of access settings that could be causing your problem , I have everything in ease of access turned off ,and get no such problems.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Aardman's new YouTube channel to share the work of independent animators

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017